directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Zoerner <ste...@labeo.de>
Subject Re: apple address book unable to connect to the ldap server
Date Mon, 17 Sep 2007 22:24:56 GMT
Hi Kevin!

Kevin Bortis wrote:
> Ok, I run ApacheDS Version 1.5.1, Thunderbird version 2.0.0.6. I
> configured Thunderbird exactly the same as in the User's Guide. I
> modified only the hostname to localhost and tested some values for
> Bind DN, which I think is the line for user authentication.
> 
> I tested values like:
> - username(uid)
> - uid=admin,ou=system
> - cn=Thomas Quist,ou=system,o=sevenSeas

I am a little bit confused by the Thunderbird dialog. It provides the 
option to enter a bind DN, but no password. And Thunderbird does not ask 
for a password, if necessary.

One option would be to enable anonymous access for the server, which 
will probably work better (leave the bind DN blank in this case).

> For apple's Address Book.app I tested:
> 
> Server: localhost
> Search Base: ou=people,o=sevenSeas
> Port: 389 ( I run ADS as root and have changed the port to this )
> Scope: Subtree ( Can also be: Base or One Level )
> 
> Authentication
> User name: tquist
> password: test ( The password I have setup for tquist in ADS Studio )
> Auth Type: Simple ( It's the only possibility )

Try username = "cn=Thomas Quist,ou=system,o=sevenSeas"
password = "test"

I assume that a user DN is expected here, although it states "User name".

> But I don't really know what I have to set in. In google I haven't
> found additional useful info's.

Greetings from Hamburg,
     Stefan



Mime
View raw message