directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alex Karasulu" <akaras...@apache.org>
Subject Re: ApacheDS 1.5.1 :: Does ApacheDS internally cache modified object properties, like changed user password
Date Fri, 20 Jul 2007 19:04:05 GMT
That was a fast response :).  Nice job ersin!

Alex

On 7/20/07, Ersin Er <ersin.er@gmail.com> wrote:
>
> OK fixed it here (also added a test):
>
> http://svn.apache.org/viewvc?view=rev&revision=558089
>
> On 7/20/07, Emmanuel Lecharny <elecharny@apache.org> wrote:
> >
> > Hi guys,
> >
> > seems to be a pb with the cache. I gonna land an eye on it, as I was the
> > last one who modified it. Will do that tomorrow.
> >
> > Alex Karasulu a écrit :
> >
> > > Hi Markus,
> > >
> > > Good to hear from you again.  Sorry about this annoying problem.
> > >
> > > Sounds like we have a credential cache issue.  I see a few JIRA issues
> > > floating
> > > around on the topic.  I'll take a look when I get a chance but my gut
> is
> > > telling me
> > > that the credentials in the cache are not invalidated by the modify on
> > > the
> > > userPassword attribute.
> > >
> > > Thanks,
> > > Alex
> > >
> > > On 7/20/07, Markus Pohle <apacheds.users@webunity.de> wrote:
> > >
> > >>
> > >> Hi list-users,
> > >>
> > >> I use ApacheDS-1.5.1-SNAPSHOT release on my computer and figured out
> > the
> > >> following:
> > >>
> > >> 1. started my webapp
> > >> 2. tried to login to my webapp, which tries to authenticate myself
> > >> against apacheds
> > >> 3. login is successful
> > >>
> > >> 4. used LDAP Studio to modify my users password
> > >> 5. started my webapp again and tried to login with modified password
> > >> with no success
> > >> 6. tried the old password and thats successful
> > >>
> > >> 7. stopped ApacheDS and started again and tried then to use the new
> > >> password and now it is successful
> > >>
> > >> Can anybody tell me, why that happens? Looked in server.xml for
> reason
> > >> and found only these two tags:
> > >> <property name="synchPeriodMillis" value="15000" />
> > >> <property name="synchOnWrite" value="true" />
> > >>
> > >> Help would be really appreciated.
> > >> TIA
> > >> Markus
> > >>
> > >
> >
> >
>
>
> --
> Ersin Er
>
> R.A. and Ph.D Student at the Dept. of Computer Eng. in Hacettepe
> University
> http://www.cs.hacettepe.edu.tr
>
> Committer and PMC Member of The Apache Directory Project
> http://directory.apache.org
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message