directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wayne Johnson" <wjohn...@mqsoftware.com>
Subject RE: Apache DS (I think) fails to load when we upgraded to Jetty 6.1.4 or 6.1.5rc0
Date Wed, 18 Jul 2007 03:33:04 GMT
I did finally figure it out.  I was missing a slf4j jarfile.  Part of my confusion was due
to the myriad of loggers and logger wrappers involved.  

Our configuration is pretty complicated with Axis, Directory Service, Slide, an HTTP server
and  a few JSP web apps running under the Tanuki Java Service Wrapper.  I apologize for not
including more but I wasn't sure how to describe it without dropping 2 dozen configuration
files on everyone.

Thanks everyone for the suggestions.


-----Original Message-----
From: akarasulu@gmail.com on behalf of Alex Karasulu
Sent: Tue 7/17/2007 4:15 PM
To: users@directory.apache.org
Subject: Re: Apache DS (I think) fails to load when we upgraded to Jetty 6.1.4 or 6.1.5rc0
 
How about providing more information on whether you have ADS embedded
running in Jetty or
in some app running both or ADS is standalone.

Alex

On 7/17/07, Wayne Johnson <wjohnson@mqsoftware.com> wrote:
>
> I am trying to upgrade our Jetty & Apache DS (1.0.0) server From Jetty
> 6.0.1 to Jetty 6.1.4 (or even Jetty 6.1.5rc0) and can't get Apache
> Directory Service to load.  Unfortunately, the only error I seem to get is:
>
> INFO   | jvm 1    | 2007/07/17 12:50:04 | 2007-07-17 12:50:04.642::WARN:  Config
> error at <New id="factory" class="
> org.springframework.context.support.FileSystemXmlApplicationContext"><Arg>jetty/server.xml</Arg><Call
> id="cfg" name="getBean"><Arg>configuration</Arg><Call id="jndi-env"
> name="toJndiEnvironment"/></Call><Call id="env"
> name="getBean"><Arg>environment</Arg><Call name="setProperty"><Arg><Get
> name="INITIAL_CONTEXT_FACTORY" class="javax.naming.Context"/></Arg><Arg>
> org.apache.directory.server.jndi.ServerContextFactory</Arg></Call><Call
> name="putAll"><Arg><Ref id="jndi-env"/></Arg></Call></Call></New>
> INFO   | jvm 1    | 2007/07/17 12:50:04 | Configuration Exception: null
>
> I'm not sure if this is a problem in Jetty, or Apache DS, or our
> configuration.  Any ideas?  Any hints on how to configure logging for a bit
> more information?  I tried adding a log4j.appender for directory service
> but still nothing.
>
> I'll also post to the Jetty mailing list as well.  Thanks.
>
> Wayne Johnson
> Senior Software Engineer
> MQSoftware, Inc.
> 1660 S Highway 100
> Minneapolis, MN 55416
> (952) 345-8628
>
>
>



Mime
View raw message