directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wayne Johnson" <wjohn...@mqsoftware.com>
Subject RE: Apache DS (I think) fails to load when we upgraded to Jetty 6.1.4 or 6.1.5rc0
Date Tue, 17 Jul 2007 19:11:40 GMT
Forgive my ignorance, but can you be a bit more specific on how to turn up logging on Spring?
 Or is that a question for the Jetty list?

> -----Original Message-----
> From: chris.custine@gmail.com 
> [mailto:chris.custine@gmail.com]On Behalf
> Of Chris Custine
> Sent: Tuesday, July 17, 2007 1:57 PM
> To: users@directory.apache.org
> Subject: Re: Apache DS (I think) fails to load when we 
> upgraded to Jetty
> 6.1.4 or 6.1.5rc0
> 
> 
> Try turning up the debug logging for Spring.  It looks like Spring is
> getting an NPE somewhere (possibly from loading ApacheDS 
> since there is no
> logging from ADS showing up yet).  If there were any calls 
> going in to ADS,
> I think you would have seen log output.  It might also be 
> some change to the
> Jetty JNDI impl?
> 
> Good luck,
> Chris
> 
> On 7/17/07, Wayne Johnson < wjohnson@mqsoftware.com> wrote:
> >
> > I am trying to upgrade our Jetty & Apache DS ( 1.0.0) 
> server From Jetty
> > 6.0.1 to Jetty 6.1.4 (or even Jetty 6.1.5rc0) and can't get Apache
> > Directory Service to load.  Unfortunately, the only error I 
> seem to get is:
> >
> > INFO   | jvm 1    | 2007/07/17 12:50:04 | 2007-07-17 12:50: 
> 04.642::WARN:  Config
> > error at <New id="factory" class="
> > 
> org.springframework.context.support.FileSystemXmlApplicationCo
> ntext"><Arg>jetty/server.xml</Arg><Call
> > id="cfg" name="getBean"><Arg>configuration</Arg><Call id="jndi-env"
> > name="toJndiEnvironment"/></Call><Call id="env"
> > name="getBean"><Arg>environment</Arg><Call 
> name="setProperty"><Arg><Get
> > name="INITIAL_CONTEXT_FACTORY" class=" 
> javax.naming.Context"/></Arg><Arg>
> > 
> org.apache.directory.server.jndi.ServerContextFactory</Arg></C
> all><Call
> > name="putAll"><Arg><Ref id="jndi-env"/></Arg></Call></Call></New>
> > INFO   | jvm 1    | 2007/07/17 12:50:04 | Configuration 
> Exception: null
> >
> > I'm not sure if this is a problem in Jetty, or Apache DS, or our
> > configuration.  Any ideas?  Any hints on how to configure 
> logging for a bit
> > more information?  I tried adding a log4j.appender for 
> directory service
> > but still nothing.
> >
> > I'll also post to the Jetty mailing list as well.  Thanks.
> >
> > Wayne Johnson
> > Senior Software Engineer
> > MQSoftware, Inc.
> > 1660 S Highway 100
> > Minneapolis, MN 55416
> > (952) 345-8628
> >
> >
> >
> 
> 

Mime
View raw message