directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tod <the.mail.lis...@gmail.com>
Subject Re: Error reading children of base DN
Date Tue, 31 Jul 2007 12:24:46 GMT
Stefan Seelmann wrote:
> Hi Tod,
> 
>> As I was trying out the LDAP Studio on other LDAP servers, I pointed it
>> to the Domino box to see if it would work.  When I tried to expand the
>> baseDn I got the following error "Error while reading entry Empty
>> Attribute is not allowed!".
> 
> Which version of LDAP Studio are you using? In 0.8.0 we fixed some
> problems with the empty DN (RootDSE).


Windows version 0.8.1.  If anyone gets a chance the current version 
might come in handy in Help->About LDAP Studio.


> Does the error occur when you just single-click on the baseDN entry to
> show the attributes. Or does it occur when you expand the baseDN entry?
> Note: a double-click causes both, reading the entrie's attributes and
> its children. Please try to do this actions separately, just to isolate
> the error.



Both.



>> I understand the error above but I need more information to track down
>> the entry(ies) causing that error.  It would be helpful if there was a
>> way to get more details from LDAP Studio so that I could discover the
>> problem with the directory and remove it, hence my post.
> 
> Unfortunately, the logging capabilities in LDAP Studio/Apache Directory
> Studio aren't satisfying yet :-(
> 
> There are two Jira issues about logging and error handling:
>   http://issues.apache.org/jira/browse/DIRSTUDIO-155
>   http://issues.apache.org/jira/browse/DIRSTUDIO-150
> Could you please add a comment with your special case so that we don't
> forget that case when fix the issues?


Sure, no problem.


> In the meantime you could take a look to the log file. It is located
> under <HOME>/ldapstudio/.metadata/.log
> 
> You could also perform a search, starting at the base DN with one-level
> scope and no returning attributes. Then you could click to every search
> result entry to see if you could read them.
> 
> Another idea is to record the transfered search request and response
> using Wireshark. Perhaps you could post such a dump here or just create
> another Jira and attach the dump.

I will give these suggestions a try and get back to the list by weeks 
end.  I'll probably Jira the network dump.


>> Incidentally, I just tried this on ADS and I get a "Error while reading
>> entry, Unprocessed Continuation Reference(s)" error when trying to
>> expand its baseDn.  That's probably better saved for a separate thread...
> 
> I guess you mean Active Directory with "ADS"? (Apache Directory Server
> uses the same acronym)


Yes sorry, no disrespect intended :)

If it helps your efforts I've been using Jarek Gawor's LDAP browser for 
what seems like the last 10 years.  I've not found anything faster or 
better until I gave this one a shot.  The Eclipse interface was a great 
decision and the tool overall is fantastic.  Kudos to the team.


- Tod

Mime
View raw message