directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Seelmann <seelm...@apache.org>
Subject Re: Error reading children of base DN
Date Mon, 30 Jul 2007 20:11:55 GMT
Hi Tod,

> As I was trying out the LDAP Studio on other LDAP servers, I pointed it
> to the Domino box to see if it would work.  When I tried to expand the
> baseDn I got the following error "Error while reading entry Empty
> Attribute is not allowed!".

Which version of LDAP Studio are you using? In 0.8.0 we fixed some
problems with the empty DN (RootDSE).

Does the error occur when you just single-click on the baseDN entry to
show the attributes. Or does it occur when you expand the baseDN entry?
Note: a double-click causes both, reading the entrie's attributes and
its children. Please try to do this actions separately, just to isolate
the error.

> I don't profess the virtues of Domino's (or ADS's) compliance with LDAP
> schema standards, I am just tasked in dealing with them :)

I feel with you ;-)

> I understand the error above but I need more information to track down
> the entry(ies) causing that error.  It would be helpful if there was a
> way to get more details from LDAP Studio so that I could discover the
> problem with the directory and remove it, hence my post.

Unfortunately, the logging capabilities in LDAP Studio/Apache Directory
Studio aren't satisfying yet :-(

There are two Jira issues about logging and error handling:
  http://issues.apache.org/jira/browse/DIRSTUDIO-155
  http://issues.apache.org/jira/browse/DIRSTUDIO-150
Could you please add a comment with your special case so that we don't
forget that case when fix the issues?

In the meantime you could take a look to the log file. It is located
under <HOME>/ldapstudio/.metadata/.log

You could also perform a search, starting at the base DN with one-level
scope and no returning attributes. Then you could click to every search
result entry to see if you could read them.

Another idea is to record the transfered search request and response
using Wireshark. Perhaps you could post such a dump here or just create
another Jira and attach the dump.

> 
> Incidentally, I just tried this on ADS and I get a "Error while reading
> entry, Unprocessed Continuation Reference(s)" error when trying to
> expand its baseDn.  That's probably better saved for a separate thread...

I guess you mean Active Directory with "ADS"? (Apache Directory Server
uses the same acronym)

King Regards,
Stefan Seelmann


Mime
View raw message