directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Emmanuel Lecharny" <elecha...@gmail.com>
Subject Re: [ApacheDS] Still can't get beyond 'mvn package' step
Date Fri, 01 Jun 2007 13:46:34 GMT
My guess is that we are just trying to use the latest SNAPSHOT for
some jar, so if you have a 1.5 ADS proviously compiled on your
computer, it might use this jar.

Not 100% sure though ....

Emmanuel

On 6/1/07, Jesse McConnell <jesse.mcconnell@gmail.com> wrote:
> whats going on? not sure I followed the original mail enough to see
> why removing the repo fixes the problem...
>
> jesse
>
> On 6/1/07, Emmanuel Lecharny <elecharny@gmail.com> wrote:
> > Yes, Jess, you are right. This is just a workaround right now. You can
> > even try to mv the repo instead of rm -rf it.
> >
> > I'm currently trying to figure out what is the real reason for this
> > *$£% problem...
> >
> > Emmanuel
> >
> > On 6/1/07, Jesse McConnell <jesse.mcconnell@gmail.com> wrote:
> > > the .m2 directory is created by maven and is where it stores the
> > > artifacts that are downloaded and used to build out the classpath when
> > > it is building each project..  the repository in that .m2 directory is
> > > what maven refers to as its local repository.
> > >
> > > as for wacking the whole .m2/repository, that can be a pain if there
> > > are some of those javax libs that are still manually required to
> > > download, or if you had to manually install things like oracle jars,
> > > you ought to be able to get away with just removing the
> > > .m2/repository/org/apache/directory folder..
> > >
> > > jesse
> > >
> > > On 5/31/07, Emmanuel Lecharny <elecharny@apache.org> wrote:
> > > > Jo Jeeka a écrit :
> > > >
> > > > >Hi again guys.
> > > > >
> > > > >
> > > >
> > > > Hi Jo,
> > > >
> > > >
> > > > >I am still stuck on the 'mvn package' step from the
> > > > >page of creating my own schema
> > > > >(http://directory.apache.org/apacheds/1.0/custom-schema.html)
> > > > >
> > > > >
> > > > I have updated the page, you have to svn co the 1.0.2 version instead
of
> > > > 1.0.1
> > > >
> > > > >I think the problem is the incompatibility of my Java
> > > > >versions from what is in some of the JARs in what I am
> > > > >trying to work with (now 1.0.2 of Apache DS).
> > > > >
> > > > >I am not really sure how the .m2 directory (see error
> > > > >below) was created and is knowned to be accessed.  I
> > > > >do have a maven directory (C:\maven-2.0.6) so did the
> > > > >.m2 directory and its contents get created sometime
> > > > >when maven was installed (and the maven-2.0.6 dir was
> > > > >created)?
> > > > >
> > > > >
> > > > I had the very same problem you had. I was pretty drastic :
> > > > rm -rf ~/.m2/repository (or whatever command on windows that wipe the
repo)
> > > > mvn clean
> > > > mvn package
> > > >
> > > > and, Magic ! it worked...
> > > >
> > > > Can you try and tell me if it's ok ?
> > > >
> > > > Thanks
> > > > Emmanuel
> > > >
> > > >
> > >
> > >
> > > --
> > > jesse mcconnell
> > > jesse.mcconnell@gmail.com
> > >
> >
> >
> > --
> > Regards,
> > Cordialement,
> > Emmanuel Lécharny
> > www.iktek.com
> >
>
>
> --
> jesse mcconnell
> jesse.mcconnell@gmail.com
>


-- 
Regards,
Cordialement,
Emmanuel Lécharny
www.iktek.com

Mime
View raw message