directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Emmanuel Lecharny <>
Subject Re: [ApacheDS] Still can't get beyond 'mvn package' step
Date Mon, 04 Jun 2007 16:57:17 GMT
Jo Jeeka a écrit :

>I took off Friday so I didn't get a chance to try
>until today...   But it worked.  Deleting .m2
>directory and running the directions again worked. 
>Thanks for sure on getting beyond that.
>Now though I have another problem.  I tried replacing
>my schema over the car schema and I get a parse error
>(seen below).
>Just to give some background which may or may not help
>get past this next error...  My custom schema I am
>trying to use was created from our LDAP guy (reminder
>for those tuning in, I'm a developer trying to set
>ApacheDS up for unit testing so I'm not an LDAP guy)
>who created an LDIF file (assuming by exporting it)
>for me and gave it to me as "our schema".  I simply
>renamed the .ldif file to be .schema. 
>Does that sound acceptable?
Well, hmmm, a LDIF file is certainly different than a schema. It's a 
little bit like if he gave you a database dump of all the data in it and 
told you "This is the database schema" ...

So, no, an ldif file is certainly not a schema. The format is totally 

Here is a tuturial about how to build a Ldap Schema :

To avoid dealing with the syntax, you can also use LdapStudio which is 
an RCP/eclipse application which contains a schema editor : You also have a help here :

Hope it helps.


View raw message