directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jo Jeeka <joje...@yahoo.com>
Subject Re: [ApacheDS] Custom schema problem adding objectclass
Date Tue, 05 Jun 2007 17:59:28 GMT


I'm pretty sure no code in MyObjectClassProducer.java
is being called (hence no custom objectclasses are
getting in)

I do see a section about editing the server.xml
(http://directory.apache.org/apacheds/1.0/custom-schema.html)
but I am not sure where I would do this.  We have a
tomcat server.xml but it has no bootstrapSchemas tag
in it already.  Also, I forget what stand alone means
for ApacheDS right this second and I am not sure if
for unit testing I need to edit any server.xml files. 


Also, on that same link I just gave, should the line
in the server.xml be <bean
class="org.apache.directory.server.core.schema.bootstrap.MySchema"/>
or com.acme.MySchema ?




--- Emmanuel Lecharny <elecharny@gmail.com> wrote:

> Hi,
> 
> On 6/5/07, Jo Jeeka <jojeeka@yahoo.com> wrote:
> >
> >
> >
> > I am close to getting my custom schema in...
> >
> >
> > I am getting this error:
> > OID for name 'groupofurls' was not found within
> the
> > OID registry
> 
> 
> Yje 'groupOfUrls' ObjectClass is not one of the
> default objectClasses in
> ADS. You will have to declare it by yourself
> 
> I thought if I added an objectclass definition in
> the
> > schema that I could use it (with nothing else). 
> Even
> > though on this page:
> >
> >
>
http://directory.apache.org/apacheds/1.5/add-your-first-elements-to-the-schema.html
> > it shows a CreateAttributeType class I thought
> that
> > this was generated after mvn package command.  I
> have
> > code generated similar to what is in the
> > CrateAttributeType class on the link above in this
> > file generated file MyObjectClassProducer.java
> >
> >
> > Bottom line, do I need to do more than declare a
> > custom objectclass in the schema for it to be
> usable?
> 
> 
> As soon as your schema contains all the needed
> ObjectClasses and
> attributeTypes you need, and if their syntax is
> correct, then you should be
> OK.
> 
> I'm confused on that.  If not, any idea why I can't
> > use it?  I have done a mvn clean and refreshed my
> > project and then ran the unit test.
> 
> 
> Can you copy/paste your actual schema ?
> Emmanuel
> -- 
> Regards,
> Cordialement,
> Emmanuel L├ęcharny
> www.iktek.com
> 



       
____________________________________________________________________________________
Be a better Globetrotter. Get better travel answers from someone who knows. Yahoo! Answers
- Check it out.
http://answers.yahoo.com/dir/?link=list&sid=396545469

Mime
View raw message