directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tony Thompson" <Tony.Thomp...@stone-ware.com>
Subject FW: [ApacheDS] Custom schema issues (again)
Date Fri, 11 May 2007 13:47:18 GMT
OK, well now we are getting somewhere.  When I run "mvn package" on the foo-schema, it is in
fact downloading the 1.5 version:

[INFO] Scanning for projects...
[INFO] ----------------------------------------------------------------------------
[INFO] Building Schema Project
[INFO]    task-segment: [package]
[INFO] ----------------------------------------------------------------------------
Downloading: http://repo1.maven.org/maven2/org/apache/directory/server/apacheds-core-plugin/1.5.0/apacheds-core-plugin-1.5.0.pom
1K downloaded
Downloading: http://repo1.maven.org/maven2/org/apache/directory/server/apacheds-core-plugin/1.5.0/apacheds-core-plugin-1.5.0.jar
44K downloaded
[INFO] [apacheds-core:generate {execution: default}]

It doesn't matter how many times I clear the repo, etc. it still downloads that file.  There
is a link below to a zip file that contains the code I checked out from the svn server and
the generated code after I did the install.  The zip file also contains a "failedrun.txt"
file that is a log of everything I did.  I am beginning to think I am doing something stupid
so hopefully with that info you can tell me what I am doing wrong.

https://webnet.stone-ware.com/dl/ads-schema.zip



-----Original Message-----
From: Emmanuel Lecharny [mailto:elecharny@apache.org]
Sent: Friday, May 11, 2007 2:00 AM
To: users@directory.apache.org
Subject: Re: [ApacheDS] Custom schema issues (again)

Tony Thompson a écrit :

>>There is no ArrayList<String> here.
>>
>>Can you just follow the exact same sequence ? I think the key is
>>    
>>
>removing the maven repository.
>  
>
>>Don't forget to svn up, as I have fixed an error in the script.
>>
>>Emmanuel
>>    
>>
>
>Well, I have tried about everything I can think of and it still does 
>the same thing.
>
Embrarassing...

>I am on a Windows machine so I am not sure if that is part of the 
>problem (it usually is).
>
I don't use windows :)

> I had a 1.4 JRE installed and I removed that but it didn't make a 
>difference.  I have my JAVA_HOME environment variable set to a 1.5 JDK 
>directory.  I wiped out the Maven repo and followed your steps and it 
>still generates the source with the generics in there.
>
This is *very* strange. The generic is stored into a velocity template which is stored into
apacheds/core-plugin/src/main/resources/org/apache/directory/server/core/tools/schema/Schema.template

If you look at this file, it should *not* contains any generic.
1.0 version can be seen here :
http://svn.apache.org/repos/asf/directory/apacheds/branches/1.0/core-plugin/src/main/resources/org/apache/directory/server/core/tools/schema/Schema.template

1.5 version is here :
http://svn.apache.org/repos/asf/directory/apacheds/trunk/core-plugin/src/main/resources/org/apache/directory/server/core/tools/schema/Schema.template

Those files are stored into
.m2/repository/org/apache/directory/server/apacheds-core-plugin/1.0.2-SNAPSHOT/apacheds-core-plugin-1.0.2-SNAPSHOT.jar
if you tries with trunk.

Can you check on your disk to see if you don't have an apacheds-core-plugin-<whatever>.jar
file which could be possibly in your path? If so, just delete those files, and give it another
try.

Emmanuel
 
This message (and any associated files) is intended only for the 
use of the individual or entity to which it is addressed and may 
contain information that is confidential, subject to copyright or
constitutes a trade secret. If you are not the intended recipient 
you are hereby notified that any dissemination, copying or 
distribution of this message, or files associated with this message, 
is strictly prohibited. If you have received this message in error, 
please notify us immediately by replying to the message and deleting 
it from your computer. Messages sent to and from Stoneware, Inc.
may be monitored.

Mime
View raw message