directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jo Jeeka <joje...@yahoo.com>
Subject [ApacheDS] mvn package command failed for the car.schema
Date Thu, 10 May 2007 19:45:02 GMT
I am getting most of the way through the tutorial
(http://directory.apache.org/apacheds/1.0/custom-schema.html)
for adding my own schema and I ran the mvn package
command (as stated under "Compiling, and running tests
on the exampe car.schema" heading.

Looks like another (I had to compile
AttributeAndTypes.java w/o StringBuilder) 1.5
incompatability for me (my whole project is 1.4.2 and
isn't going to 1.5 anytime soon because we are having
trouble upgrading to the Weblogic that supports 1.5).

Now on the mvn package command for the car.schema (not
even at dealing with my own schema yet) I get the
following:

urls[8] = file:/C:/Documents and
Settings/JoJ/.m2/repository/antlr/antlr/2.7.6/antlr-2.7.6.jar
urls[9] = file:/C:/Documents and
Settings/JoJ/.m2/repository/org/apache/directory/shared/shared-asn1/0.9.6/shared-asn
1-0.9.6.jar
Number of imports: 4
import: org.codehaus.classworlds.Entry@4891bb28
import: org.codehaus.classworlds.Entry@f8e44ca4
import: org.codehaus.classworlds.Entry@c51bc9e7
import: org.codehaus.classworlds.Entry@bece5185


this realm = plexus.core
urls[0] =
file:/C:/maven-2.0.6/bin/../lib/maven-core-2.0.6-uber.jar
Number of imports: 4
import: org.codehaus.classworlds.Entry@4891bb28
import: org.codehaus.classworlds.Entry@f8e44ca4
import: org.codehaus.classworlds.Entry@c51bc9e7
import: org.codehaus.classworlds.Entry@bece5185
-----------------------------------------------------
[ERROR] BUILD ERROR
[INFO]
------------------------------------------------------------------------
[INFO] Internal error in the plugin manager executing
goal
'org.apache.directory.server:apacheds-core-plugin:1.5.0:gener
ate': Unable to find the mojo
'org.apache.directory.server:apacheds-core-plugin:1.5.0:generate'
in the plugin 'org.apach
e.directory.server:apacheds-core-plugin'
org/apache/directory/server/core/tools/schema/DirectorySchemaToolMojo
(Unsupported major.minor version 49.0)




Does that mean I need an older version of Maven (or
need to compile Maven myself)?  Or is the version
incompatability in code from ApacheDS?





__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 

Mime
View raw message