directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alex Karasulu" <akaras...@apache.org>
Subject Re: [ApacheDS] Having problems with schemas in 1.5
Date Tue, 24 Apr 2007 17:23:19 GMT
Hi Stefan,

I specifically had worked a JIRA issue to make sure the modify timestamp on
the
schema subentry at cn=schema was modified when there were any changes to
schema entries made via cn=schema modifs or changes made directly on schema
entries under ou=schema.  However I may have botched this.  I'm very
interested
in finding out if the timestamp update is failing.

Alex

On 4/24/07, Stefan Seelmann <mail@stefan-seelmann.de> wrote:
>
> Hi Damien,
>
> Damien Tougas schrieb:
> >
> > No matter what I have tried, I have not been able to get LDAP Studio to
> > recognize the new schema. I have tried re-connecting to ApacheDS,
> > stopping/restarting the ApacheDS server, etc. LDAP Studio does not want
> > to recognize the schema.
> >
> > I then tested using LDAP Explorer. LDAP Explorer allowed me to see the
> > new schema elements and use them (the interface is really bad though!).
> > It looks like this is probably a problem with LDAP Studio, and not
> > ApacheDS.
> >
>
> Could you please try the following? Please open the schema browser
> (right-click to the connection, then select 'Open Schema Browser'). In
> the schema browser please press the 'Refresh' button. This forces LDAP
> Studio to reload the schema from the server.
>
> If this doesn't help you could try to delete the connection and create
> it again.
>
> LDAP Studio caches the schema and reloads it only if the schema has
> changes, this is done my comparing the modifyTimestamp of the schema.
> Perhaps there is problem with that, I will investigate on that.
>
> Best Regards,
> Stefan Seelmann
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message