directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alex Karasulu" <akaras...@apache.org>
Subject Re: [ApacheDS] Having problems with schemas in 1.5
Date Mon, 23 Apr 2007 03:02:11 GMT
Damien,

On 4/22/07, Damien Tougas <damien@tougas.net> wrote:
>
> Hello,
>
> I am in the process of checking out the directory server for the first
> time. I am by no means an LDAP expert, but so far I like what I am
> seeing here. My end goal for this testing is to create a shared address
> book using the mozillaAbPersonAlpha schema:
>
> http://wiki.mozilla.org/MailNews:Mozilla_LDAP_Address_Book_Schema
>
> I was able to open the schema in LDAP Studio and export it to an LDIF.
> The first problem I encountered was that the exported LDIF had a typo
> which caused the import to fail. The typo was in this section (note the
> spelling of "matchingRules" in the dn):
>
>         dn: ou=macthingRules, cn=moz, ou=schema
>         objectclass: organizationalUnit
>         objectclass: top
>         ou: matchingrules
>
> Once that was fixed, the import worked without any errors.


Ahhh ok I think this can be fixed easily in LdapStudio or one of the shared
libraries it depends on which probably is responsible for this typo.  Could
you file a JIRA issue for it
here:

   https://issues.apache.org/jira/browse/DIRSTUDIO

The next problem I encountered was the fact that the directory server
> didn't know what to do with the syntax lengths. This problem did not
> show up when I did the import, but it caused exceptions to get thrown
> when re-starting the directory server.


This is not good.  Perhaps you can file a JIRA issue about this.  I think
this may be a bug in the schema subsystem but we need to figure it out.
Could you attach the LDIF file to the JIRA as an 'attachment'?  You can file
the JIRA issue for it here:

   https://issues.apache.org/jira/browse/DIRSERVER

To deal with that problem I simply removed the syntax length definitions
> from the exported LDIF (i.e. removed {128} etc.) and did the import
> again (I first had to delete the schemas partition directory in order to
> be able to do this, I am not sure if there is a better way...).


Yeah this should have worked hence why I think it's a bug in the schema
subsystem.

After doing all of that, everything appears to be fine. I cannot,
> however, see the mozillaAbPersonAlpha object class show up in the list
> when trying to add a new entry using LDAP Studio. Is there anything else
> I need to be doing in order to make this new schema active for a
> particular partition?


I need to narrow down what is causing this: whether it is due to LS or
ApacheDS.  I think it's ApacheDS.  Perhaps the schema has not been enabled
for some reason.  Do me a favor and connect to the server and look at the
cn=moz,ou=schema entry.  Perhaps you can post it's attributes/LDIF here.
But just checking if an m-disabled attribute is present on the entry may
suffice.  If this m-disabled attribute is set to TRUE just modify the entry
so it is set to FALSE or remove the m-disabled attribute altogether.

I think by default newly added schema are disabled.

Alex

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message