directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alex Karasulu" <akaras...@apache.org>
Subject Re: [ApacheDS] 1.5 Experience Not Good on Windows
Date Mon, 23 Apr 2007 02:45:21 GMT
Hi Mike,

Good to see you pushing this email after our talk on IRC.  Hopefully others
can shed some light on the Kerberos specific issues you are having.  More
inline ...

On 4/22/07, CORUM, M E [AG/1000] <m.e.corum@monsanto.com> wrote:
>
>
> Have others successfully installed and run 1.5 if they previously had
> 1.0.1 (on Windows)?  The reason I ask is that the 1.5 installer doesn't
> work unless you not only uninstall 1.0.1 but manually edit the Windows
> registry to fix up the paths.  Once I did that, I could get the server
> to come up.


Basically the uninstaller should remove all the registry settings.  If not
then
we have a problem.  Can you confirm that the uninstaller in fact does this
on
your machine and report back to us?

The next problem comes when I try to import the example data like I did
> in my 1.0.1 server.  When I run the import in 1.5, I get:
>
> Exception in thread "main" java.lang.NoClassDefFoundError:
> org/apache/directory/shared/asn1/Asn1Object
>         at
> org.apache.directory.server.tools.commands.importcmd.ImportCommandExe
> cutorSkeleton.execute(ImportCommandExecutorSkeleton.java:34)
>         at
> org.apache.directory.server.tools.commands.importcmd.ImportCommandExe
> cutorStub.execute(ImportCommandExecutorStub.java:36)
>         at
> org.apache.directory.server.tools.request.BaseToolCommandCL.execute(B
> aseToolCommandCL.java:67)
>         at
> org.apache.directory.server.tools.ApachedsTools.main(ApachedsTools.ja
> va:122)
>
> The interesting thing is that I still get it even if I add a -classpath
> to include the shared-asn1-0.9.6.jar which has that class.  Here is the
> command:
>
> C:\apacheds-1.5\bin>java -classpath
> C:\apacheds-1.5\lib\shared-asn1-0.9.6.jar -jar apacheds-tools.jar import
> -f data.ldif -w somedifferentpassword


Sounds to me like you've got an old 1.0.1 version of the tools jar sitting
around
somewhere.  First things first just make sure you clean up with a complete
uninstall
and make sure all the directories are completely removed.  If some still
persist
just remove them manually.

I was hoping that the Kerberos stuff worked better in 1.5 (I couldn't
> get it to work in 1.0.1 even after finding the hidden docs on the
> internet).
>
> Any help would be much appreciated.


I think Enrique could lend a hand with this.  Enrique could you give Mike
some more info on
how to use the Kerberos server in 1.5?

Alex

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message