directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alex Karasulu" <akaras...@apache.org>
Subject Re: Problem starting ApacheDS on Ubuntu 64
Date Thu, 19 Apr 2007 19:36:16 GMT
Hi Matt,

On 4/19/07, Matthew Schmidt <matt@dzone.com> wrote:
>
> Hi folks.  We've been evaluating ApacheDS 1.5 for the last few days and
> have had some problems getting it to run in any mode other than debug.
> When we run the startup script on Ubuntu 64 we get the following:


Oh yeah we have an issue with 64 bit architectures because of JSVC.  An
issue in JIRA has been filed for this ...

https://issues.apache.org/jira/browse/DIRSERVER-751

What I will do is bump up this issue to be fixed ASAP for 1.5.1 and
1.0.2releases.  For
1.5.1 though you'll have to build the server from the trunk until we release
1.5.1.  This should not be so hard to do.

Just watch this issue and I should be able to get a fix to you soon.  I have
a 64 bit ubuntu machine here at work that I can use to compile jsvc for the
64 bit platform.

SNIP ...


> I think that the problem is the apacheds file is a 32-bit binary.


Right on!

Is
> there a way to run the Java process in the background without this
> binary file?  I tried building apache ds from subversion and got the
> same error.



Well yeah it's not that hard to make ADS do this.  All you would have to do
is edit the init script.  Basically replace the start case logic that uses
jsvc with the debug case logic and just remove the debugging parameters to
java.  Oh and you might also want to put a nohup command in there too so you
can detach from the console.

Let us know if this workaround actually works.

Alex

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message