directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "CORUM, M E [AG/1000]" <m.e.co...@monsanto.com>
Subject RE: [ApacheDS] 1.5 Experience Not Good on Windows - More Info - Trying to get basic Import to Work
Date Mon, 23 Apr 2007 03:09:37 GMT
Alex,

Thanks, I was using 1.5.  I don't even have 1.4 on my machine any more.
However, I found that some of my Kerberos jars actually conflicted with
the ASN.1 stuff in ApacheDS.  After I fixed that, the issue is that in
1.0.1, the import command line utility is very clean and doesn't require
any special classpath (or if it does, it handles it internally with the
classpath entry in the manifest file).  Woops, as I was typing this, I
found the error in 1.5.  The tools jar in the /bin directory has the
same classpath entry in the manifest file as follows:

../lib/shared-asn1-0.9.6-SNAPSHOT.jar

However, the /lib directory has:

shared-asn1-0.9.6.jar (without SNAPSHOT)

The only thing I can think is that 1.0.1 just didn't need ASN.1 for the
import command line utility because it shouldn't have worked there
either but it did.

Anyway, I was able to get an import to work after setting up a special
module in IntelliJ to just bring in only the specific jars I needed for
import and not extras.  Perhaps this should be a bug report against the
manifest file in the tools jar.

At this point, I'm on 1.5 trying to get Kerberos to work.  I can't
figure out whether I should use the "before" or "after" section of
configuration on this link:
http://cwiki.apache.org/DIRxSBOX/kerberos-protocol-configuration.html.

MikeC

-----Original Message-----
From: akarasulu@gmail.com [mailto:akarasulu@gmail.com] On Behalf Of Alex
Karasulu
Sent: Sunday, April 22, 2007 9:46 PM
To: users@directory.apache.org
Subject: Re: [ApacheDS] 1.5 Experience Not Good on Windows - More Info -
Trying to get basic Import to Work

Ahhh yeah 1.5 is strictly for JDK 1.5.  If you're trying to use 1.4 it
will
bomb out.

Alex

On 4/22/07, CORUM, M E [AG/1000] <m.e.corum@monsanto.com> wrote:
>
>
> I wired it all up in IntelliJ because I kept finding more Jar files
that
> the import utility needed so I just added all the /lib jars and set up
a
> config in IntelliJ and ran it.  It looks from the error like some jars
> are Java 1.4 and others are Java 1.5.  Perhaps the attempt to go to
Java
> 1.5 isn't complete in ApacheDS 1.5?  Again, any help would be
> appreciated.  I'm just trying to load the example data file.  It
worked
> great in 1.0.1.  Should I just go back to 1.0.1 and continue trying to
> figure out the Kerberos there?
>
> MikeC
>
> Exception in thread "main" java.lang.IncompatibleClassChangeError
>         at
>
org.apache.directory.shared.asn1.ber.grammar.AbstractGrammar.<clinit>(Ab
> stractGrammar.java:48)
>         at
>
org.apache.directory.shared.ldap.codec.LdapMessageContainer.<init>(LdapM
> essageContainer.java:76)
>         at
>
org.apache.directory.shared.ldap.codec.LdapMessageContainer.<init>(LdapM
> essageContainer.java:64)
>         at
>
org.apache.directory.server.tools.commands.importcmd.ImportCommandExecut
> or.<init>(ImportCommandExecutor.java:114)
>         at
>
org.apache.directory.server.tools.commands.importcmd.ImportCommandExecut
> orSkeleton.execute(ImportCommandExecutorSkeleton.java:34)
>         at
>
org.apache.directory.server.tools.commands.importcmd.ImportCommandExecut
> orStub.execute(ImportCommandExecutorStub.java:36)
>         at
>
org.apache.directory.server.tools.request.BaseToolCommandCL.execute(Base
> ToolCommandCL.java:67)
>         at
>
org.apache.directory.server.tools.ApachedsTools.main(ApachedsTools.java:
> 122)
>         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>         at
>
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.jav
> a:39)
>         at
>
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessor
> Impl.java:25)
>         at java.lang.reflect.Method.invoke(Method.java:585)
>         at
> com.intellij.rt.execution.application.AppMain.main(AppMain.java:90)
>
> -----Original Message-----
> From: CORUM, M E [AG/1000] [mailto:m.e.corum@monsanto.com]
> Sent: Sunday, April 22, 2007 9:13 PM
> To: users@directory.apache.org
> Subject: RE: [ApacheDS] 1.5 Experience Not Good on Windows
>
>
> Have others successfully installed and run 1.5 if they previously had
> 1.0.1 (on Windows)?  The reason I ask is that the 1.5 installer
doesn't
> work unless you not only uninstall 1.0.1 but manually edit the Windows
> registry to fix up the paths.  Once I did that, I could get the server
> to come up.
>
> The next problem comes when I try to import the example data like I
did
> in my 1.0.1 server.  When I run the import in 1.5, I get:
>
> Exception in thread "main" java.lang.NoClassDefFoundError:
> org/apache/directory/shared/asn1/Asn1Object
>         at
> org.apache.directory.server.tools.commands.importcmd.ImportCommandExe
> cutorSkeleton.execute(ImportCommandExecutorSkeleton.java:34)
>         at
> org.apache.directory.server.tools.commands.importcmd.ImportCommandExe
> cutorStub.execute(ImportCommandExecutorStub.java:36)
>         at
> org.apache.directory.server.tools.request.BaseToolCommandCL.execute(B
> aseToolCommandCL.java:67)
>         at
> org.apache.directory.server.tools.ApachedsTools.main(ApachedsTools.ja
> va:122)
>
> The interesting thing is that I still get it even if I add a
-classpath
> to include the shared-asn1-0.9.6.jar which has that class.  Here is
the
> command:
>
> C:\apacheds-1.5\bin>java -classpath
> C:\apacheds-1.5\lib\shared-asn1-0.9.6.jar -jar apacheds-tools.jar
import
> -f data.ldif -w somedifferentpassword
>
> I was hoping that the Kerberos stuff worked better in 1.5 (I couldn't
> get it to work in 1.0.1 even after finding the hidden docs on the
> internet).
>
> Any help would be much appreciated.
>
> MikeC
>
>
>
>
>
------------------------------------------------------------------------
> ---------------------------------
> This e-mail message may contain privileged and/or confidential
> information, and is intended to be received only by persons entitled
to
> receive such information. If you have received this e-mail in error,
> please notify the sender immediately. Please delete it and all
> attachments from any servers, hard drives or any other media. Other
use
> of this e-mail by you is strictly prohibited.
>
>
> All e-mails and attachments sent and received are subject to
monitoring,
> reading and archival by Monsanto. The recipient of this e-mail is
solely
> responsible for checking for the presence of "Viruses" or other
> "Malware". Monsanto accepts no liability for any damage caused by any
> such code transmitted by or accompanying this e-mail or any
attachment.
>
------------------------------------------------------------------------
> ---------------------------------
>
>
>
>
>
------------------------------------------------------------------------
---------------------------------
> This e-mail message may contain privileged and/or confidential
> information, and is intended to be received only by persons entitled
to
> receive such information. If you have received this e-mail in error,
please
> notify the sender immediately. Please delete it and all attachments
from any
> servers, hard drives or any other media. Other use of this e-mail by
you is
> strictly prohibited.
>
>
> All e-mails and attachments sent and received are subject to
monitoring,
> reading and archival by Monsanto. The recipient of this e-mail is
solely
> responsible for checking for the presence of "Viruses" or other
"Malware".
> Monsanto accepts no liability for any damage caused by any such code
> transmitted by or accompanying this e-mail or any attachment.
>
>
------------------------------------------------------------------------
---------------------------------
>
>

---------------------------------------------------------------------------------------------------------
This e-mail message may contain privileged and/or confidential information, and is intended
to be received only by persons entitled to receive such information. If you have received
this e-mail in error, please notify the sender immediately. Please delete it and all attachments
from any servers, hard drives or any other media. Other use of this e-mail by you is strictly
prohibited.


All e-mails and attachments sent and received are subject to monitoring, reading and archival
by Monsanto. The recipient of this e-mail is solely responsible for checking for the presence
of "Viruses" or other "Malware". Monsanto accepts no liability for any damage caused by any
such code transmitted by or accompanying this e-mail or any attachment.
---------------------------------------------------------------------------------------------------------


Mime
View raw message