directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "CORUM, M E [AG/1000]" <m.e.co...@monsanto.com>
Subject RE: [ApacheDS] 1.5 Experience Not Good on Windows
Date Mon, 23 Apr 2007 02:12:56 GMT

Have others successfully installed and run 1.5 if they previously had
1.0.1 (on Windows)?  The reason I ask is that the 1.5 installer doesn't
work unless you not only uninstall 1.0.1 but manually edit the Windows
registry to fix up the paths.  Once I did that, I could get the server
to come up.

The next problem comes when I try to import the example data like I did
in my 1.0.1 server.  When I run the import in 1.5, I get:

Exception in thread "main" java.lang.NoClassDefFoundError:
org/apache/directory/shared/asn1/Asn1Object
        at
org.apache.directory.server.tools.commands.importcmd.ImportCommandExe
cutorSkeleton.execute(ImportCommandExecutorSkeleton.java:34)
        at
org.apache.directory.server.tools.commands.importcmd.ImportCommandExe
cutorStub.execute(ImportCommandExecutorStub.java:36)
        at
org.apache.directory.server.tools.request.BaseToolCommandCL.execute(B
aseToolCommandCL.java:67)
        at
org.apache.directory.server.tools.ApachedsTools.main(ApachedsTools.ja
va:122) 

The interesting thing is that I still get it even if I add a -classpath
to include the shared-asn1-0.9.6.jar which has that class.  Here is the
command:

C:\apacheds-1.5\bin>java -classpath
C:\apacheds-1.5\lib\shared-asn1-0.9.6.jar -jar apacheds-tools.jar import
-f data.ldif -w somedifferentpassword

I was hoping that the Kerberos stuff worked better in 1.5 (I couldn't
get it to work in 1.0.1 even after finding the hidden docs on the
internet).

Any help would be much appreciated.

MikeC




---------------------------------------------------------------------------------------------------------
This e-mail message may contain privileged and/or confidential information, and is intended
to be received only by persons entitled to receive such information. If you have received
this e-mail in error, please notify the sender immediately. Please delete it and all attachments
from any servers, hard drives or any other media. Other use of this e-mail by you is strictly
prohibited.


All e-mails and attachments sent and received are subject to monitoring, reading and archival
by Monsanto. The recipient of this e-mail is solely responsible for checking for the presence
of "Viruses" or other "Malware". Monsanto accepts no liability for any damage caused by any
such code transmitted by or accompanying this e-mail or any attachment.
---------------------------------------------------------------------------------------------------------


Mime
View raw message