directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Damien Tougas <dam...@tougas.net>
Subject Re: [ApacheDS] Having problems with schemas in 1.5
Date Tue, 24 Apr 2007 14:10:49 GMT
Hello Stefan,

I have done a little more testing myself...

Stefan Zoerner wrote:
> I have tested the steps in LDAP Studio 0.7 like this:
> 
> 1. Load the LDIF provided with my mail (TRUE instead of true) to a fresh 
> ApacheDS 1.5.1 SNAPSHOT instance

I stared out by doing the same thing, loading the LDIF with the TRUE values.

> Please not that LDAP Studio does not know the new Schema elements yet, 
> because it already has loaded the schema, and does not seem to reload it 
> automatically after an LDIF import.
> This is not an error from my point of view (in almost all cases, an LDIF 
> will provide normal entry and no schema elements).
> The problem occurs with other tools, Softerra LDAP Administrator for 
> instance -- you have to enforce schema reloading.
> 
> One option to solve this is to close the connection to ApacheDS and 
> afterwards reconnect.

No matter what I have tried, I have not been able to get LDAP Studio to 
recognize the new schema. I have tried re-connecting to ApacheDS, 
stopping/restarting the ApacheDS server, etc. LDAP Studio does not want 
to recognize the schema.

I then tested using LDAP Explorer. LDAP Explorer allowed me to see the 
new schema elements and use them (the interface is really bad though!). 
It looks like this is probably a problem with LDAP Studio, and not ApacheDS.

Thank you very much for your help.

-- 
Damien Tougas

Mime
View raw message