directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Zoerner <ste...@labeo.de>
Subject Re: [ApacheDS] Having problems with schemas in 1.5
Date Tue, 24 Apr 2007 09:07:49 GMT
Hi Damien!

Damien Tougas wrote:
> I was able to load your attache LDIF but I am still not able to use it 
> with LDAP Studio. The mozillaAbPersonAlpha object class still does not 
> show up in the list of available types when I try to add a new entry. 
> Perhaps I am encountering a bug with LDAP Studio? How are you using it?

I have tested the steps in LDAP Studio 0.7 like this:

1. Load the LDIF provided with my mail (TRUE instead of true) to a fresh 
ApacheDS 1.5.1 SNAPSHOT instance

Please not that LDAP Studio does not know the new Schema elements yet, 
because it already has loaded the schema, and does not seem to reload it 
automatically after an LDIF import.
This is not an error from my point of view (in almost all cases, an LDIF 
will provide normal entry and no schema elements).
The problem occurs with other tools, Softerra LDAP Administrator for 
instance -- you have to enforce schema reloading.

One option to solve this is to close the connection to ApacheDS and 
afterwards reconnect.

2. Create a new entry below dc=example,dc=com. Here is the modification log

#!RESULT OK
#!CONNECTION ldap://zanzibar:10389
#!DATE 2007-04-24T11:05:58.734
dn: cn=Tori Amos,dc=example,dc=com
changetype: add
objectClass: person
objectClass: top
objectClass: mozillaAbPersonAlpha
cn: Tori Amos

Note that you can't use mozillaAbPersonAlpha alone, because it is only a 
auxiliary class.

I hope this helps.
Greetings from Wiesbaden,
     Stefan Zoerner (szoerner)



Mime
View raw message