directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Damien Tougas <dam...@tougas.net>
Subject [ApacheDS] Having problems with schemas in 1.5
Date Mon, 23 Apr 2007 01:44:17 GMT
Hello,

I am in the process of checking out the directory server for the first
time. I am by no means an LDAP expert, but so far I like what I am
seeing here. My end goal for this testing is to create a shared address
book using the mozillaAbPersonAlpha schema:

http://wiki.mozilla.org/MailNews:Mozilla_LDAP_Address_Book_Schema

I was able to open the schema in LDAP Studio and export it to an LDIF. 
The first problem I encountered was that the exported LDIF had a typo 
which caused the import to fail. The typo was in this section (note the 
spelling of "matchingRules" in the dn):

	dn: ou=macthingRules, cn=moz, ou=schema
	objectclass: organizationalUnit
	objectclass: top
	ou: matchingrules

Once that was fixed, the import worked without any errors.

The next problem I encountered was the fact that the directory server 
didn't know what to do with the syntax lengths. This problem did not 
show up when I did the import, but it caused exceptions to get thrown 
when re-starting the directory server.

To deal with that problem I simply removed the syntax length definitions 
from the exported LDIF (i.e. removed {128} etc.) and did the import 
again (I first had to delete the schemas partition directory in order to 
be able to do this, I am not sure if there is a better way...).

After doing all of that, everything appears to be fine. I cannot, 
however, see the mozillaAbPersonAlpha object class show up in the list 
when trying to add a new entry using LDAP Studio. Is there anything else 
I need to be doing in order to make this new schema active for a 
particular partition?

Thanks for your help!

-- 
Damien Tougas


Mime
View raw message