directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Emmanuel Lecharny" <elecha...@gmail.com>
Subject Re: apacheds-1.0.2-SNAPSHOT startup failure
Date Wed, 28 Mar 2007 13:12:53 GMT
Hi Makus !

thanks to be so tenacious :)

On 3/28/07, Markus Pohle <markus.pohle@webunity.de> wrote:
>
> Hi there,
>
> as building the apacheds-1.0.2 snapshot was successful i tried to
> start it up. what i did is that i only used the java .jar files and
> fired up the server with a self written shell script. as server
> configuration file i used my 1.0.0 server.xml file.


you have a script in apacheds/server-main : apacheds.sh which can be used to
start the server. It will use the server.xml in this directory. Your own
script seems correct, so far.

shell script is here:
> http://www.douglas-informatik.de/apacheds/startApacheDs.sh
> server.xml is here:
> http://www.douglas-informatik.de/apacheds/server.xml.orig
>
> what happened when i fired up the apacheds is the following:
> [14:04:37] WARN
> [
> org.apache.directory.server.core.schema.AttributeTypeRegistryMonitorAdapter
> ]
> - Failed to look up the attribute type registry:1.2.6.1.4.1.
> 18060.1.1.1.3.1
> javax.naming.NamingException: attributeType w/ OID
> 1.2.6.1.4.1.18060.1.1.1.3.1 not registered!
>  <snip/>
>
> any idea why this happened?


Could you test the default script? I think that the schema files are not
loaded, as they may not be included into jars just after you have compiled
the server, but they are .class somwhere in apacheds/core-plugin (don't
remember exactly where this schema classes are generated)

what i tried then is to modify the server.xml config file that was
> build thru maven install process of 1.0.2 version. the modified
> server.xml file can be found here:
> http://www.douglas-informatik.de/apacheds/server.xml.modified


Seems ok to me.

i then fired up the server what was successful and then connected
> against the server with JXplorer ldap tool. i then tried to import a
> ldif file, which i could process successfully with the 1.0.0 version
> and the following error occured:


<advertizement>May be you can give a try to LdapStudio :
http://directory.apache.org/ldapstudio/ </advertizement> :-)

An error occured while processing the LDIF file:
> javax.naming.NameAlreadyBoundException: [LDAP: error code 68 - failed
> to add entry dc=VERWALTUNG,dc=douglasholding:
> 0.9.2342.19200300.100.1.25=verwaltung,
> 0.9.2342.19200300.100.1.25=douglasholding already exists!]; remaining name
> 'dc=VERWALTUNG,dc=douglasholding
>
> anybody an idea why this happened?


 The entry dc=verwaltung, dc=douglasholding already exists into your ldap
server. You have an option which allow you to continue on error (at least in
ldapStudio, don't remember about JXplorer) you can set. However, another
solution would be to completely remove the backend files (in a directory
named server-work).

thx
> Markus
>

-- 
Cordialement,
Emmanuel L├ęcharny
www.iktek.com

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message