directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alex Karasulu" <akaras...@apache.org>
Subject Re: Apache DS on AIX 5.3 on Power5
Date Tue, 27 Mar 2007 14:14:57 GMT
Hi Markus,


On 3/26/07, Markus Pohle <apache.ds@webunity.de> wrote:

> Hi there,
>
> I am very sorry but still the same error message... commenting out
> like seen below did not solve the problem... any other idea why this
> happens?


Hmmm ok let's look again.



> Alex Karasulu wrote: "Looks like the maven plugin for building
> installers bombed out on you.  This makes sense since it probably did
> not recognize the OS."
> Well, I am not sure why this should happen, 'cause I am on a Windows
> XP SP2 system, which should berecognized correctly, shouldn't it?


Oooops I thought you were building on AIX sorry for that.

snip ..


> >> I tried to run Apache DS on AIX 5.3 TL5 on Power5 Architectur - but
> >> with no success. I read this thread "Startup without binary" from
> >> Juergen Weber from Feb, 06, 2007 what made me think of building Apache
> >> DS from Source on my Windows XP system and then use this version and
> >> work with the jar files without the platform depending daemon files. I
> >> need to do this on Windows because on the AIX 5.3 TL5 machine I do not
> >> have svn nor internet access nor any other development resources. Only
> >> an IBM JDK in version 1.4.2 and 1.5. So, what I did is the following:


I presume everything you're doing here to be on Windows XP then ...



> >> checked out from SVN with the following command:
> >> svn co
> >>
> >>
> http://svn.apache.org/repos/asf/directory/apacheds/branches/1.0-with-dependencies/
> >> apacheds-10-trunks
> >> cd to apacheds-10-trunks and did a "mvn install" - result was "build
> >> successful"
> >> then went to server-installers and did a "mvn install" - result was an
> >> error


Ok so you're trying to build the installers.  This error message is very
weird.  I have nave not
seen this error message at all.  However let's try to understand what maven
is trying to do or
tell us:

>> [INFO] Internal error in the plugin manager executing goal
>> 'org.apache.maven.plugins:maven-site-plugin:2.0-SNAPSHOT:site': Unable
>> to find the mojo
>> 'org.apache.maven.plugins:maven-site-plugin:2.0-SNAPSHOT:site' in the
>> plugin 'org.apache.maven.plugins:maven-site-plugin'

Looks like something changed in a snapshot plugin that is used by
installer.  Try this
to see if it removes the step used to build the site and documentation
during the build
of the installers.

Edit the pom.xml in the server-installers directory.  Then remove or comment
out the
following lines from it:

<!--
          <svnBaseUrl>
            http://svn.apache.org/repos/asf/directory/apacheds/branches/1.0
          </svnBaseUrl>
          <packageSources>true</packageSources>
          <packageDocs>true</packageDocs>
-->

Now give the mvn install a try again. This should bypass the step used to
export the code
from svn and build the documentation which is triggering this mvn bug.  Let
me know how
that goes.  If this does not work out I'll have to work with you on your
machine.  We can
setup some time for that perhaps.

Alex

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message