directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ersin Er" <ersin...@gmail.com>
Subject Re: [ApacheDS Authorization] HELP - Server will no longer start
Date Fri, 23 Mar 2007 22:04:35 GMT
On 3/24/07, Tim Quinn <jpyobjcdude@gmail.com> wrote:
>
> On 3/23/07, Ersin Er <ersin.er@gmail.com> wrote:
> >
> > Hi,
> >
> > Can you please post the ACIItem you have written?
> >
> > On 3/22/07, Tim Quinn <jpyobjcdude@gmail.com> wrote:
> > >
> > > I've been playing around with ACI and am getting the following barf on
> > > server startup (which fails):
> > >
> > > 2007-03-21 23:51:18,375 [Thread-0] WARN  191 TupleCache.subentryAdded-
> > > ACIItem parser failure on 'null'. Cannnot add ACITuples to TupleCache.
> > > java.text.ParseException: Parser failure on ACIItem:
> > >         {
> > >     identificationTag "enableSearchForAllUsers",
> > >     precedence 14,
> > >     ....
> > > }
> > > Antlr exception trace:
> > > unexpected token: name
> > >         at org.apache.directory.shared.ldap.aci.ACIItemParser.parse(
> > > ACIItemParser.java:128)
> > >         at
> > org.apache.directory.server.core.authz.TupleCache.subentryAdded
> > > (
> > > TupleCache.java:186)
> > >         at
> org.apache.directory.server.core.authz.TupleCache.initialize(
> > > TupleCache.java:139)
> > >         at org.apache.directory.server.core.authz.TupleCache.<init>(
> > > TupleCache.java:101)
> > >         at
> > > org.apache.directory.server.core.authz.AuthorizationService.init(
> > > AuthorizationService.java:173)
> > >         at
> > >
> org.apache.directory.server.core.interceptor.InterceptorChain.register0(
> > > InterceptorChain.java:436)
> > >         at
> > > org.apache.directory.server.core.interceptor.InterceptorChain.register
> (
> > > InterceptorChain.java:395)
> > >         at
> > > org.apache.directory.server.core.interceptor.InterceptorChain.init(
> > > InterceptorChain.java:260)
> > > ...
> > >
> > > ~end~
> > >
> > > I have tried turning off accessControlEnabled to see if that allows me
> > to
> > > start the server but it does not. How to I fix this entry?
> > >
> > > I seem to be snookered at the moment :(
> > >
> > > Thanks,
> > > JsD
> > >
> >
> >
> >
> > --
> > Ersin
> >
>
> Hello Ersin,
>
> The syntax that I had contained a trivial error that I have since fixed.
> The
> main problem I had was that I could not bring the server back up to fix
> this
> syntax error. This caused a bit of a scare for me.
>
> Since I know that others will experience the same, maybe there should be a
> patch put into authz.AuthorizationService to detect the
> accessControlEnabled
> setting in the server config.xml and not completely block the server
> startup
> if accessControlEnabled is set to false...?


As it's currently implemented if accessControlEnabled is set to false
authz.AuthorizationService does not make any authorization operations and
just bypasses the requests (and responses). So you rproblem may be related
to something different.

..JsD
>

-- 
Ersin

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message