directory-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alex Karasulu" <akaras...@apache.org>
Subject Re: [Triplesec] User Authentication problem in Windows XP
Date Thu, 01 Mar 2007 04:55:18 GMT
On 2/28/07, Arnab Hazra <arnab.hazra@mindteck.com> wrote:
>
> Hi,
>
> I am using Triplesec 0.7.1 server in a Windows XP operating system with
> JDK 1.4.2 and Tomcat 4.1.34 installed.
>
> I am running HausKeys-0.7 downloaded from the link
> http://dist.safehaus.org/hauskeys to generate OTP. I have also downloaded
> the HausKeys build (Revision 592, trunk/) from
> https://svn.safehaus.org/repos/hauskeys. I am running the HausKeys
> application using WTK2.2 emulator.
>
> Now, I have the following queries:
>   a.. I am able to login to the SafeHaus demo page using a local username
> and password e.g. 'mcurie', 'secret'.


Probably won't work on the demo site that's at safehaus.  But in your local
installation of the application it should work.  The reason for this is the
HOTP counter might have advanced too far on that server for users using it
already since the account is shared for testing.

However, I am not able to do so for Hauskeys users like 'codehaus' etc.
> Incase, of login using 'codehaus' I have tried the ten listed HOTPs given in
> the section "Test Connectivity with a Kerberos Client" in the User Guide. Is
> this the right way for login as 'codehaus' Hauskeys user?


Should be but again I don't know if you're using the live demo on the
internet or your own setup with your own server.

  b.. I have also tried to generate the OTPs using the
HausKeys-0.7application running on an emulator and tried to login as
'codehaus' but
> without much success. Is this the right way to generate the OTP?


You can use an emulator I guess however I've just downloaded it onto my
phone.  Should work in theory.

  c.. I have observed that while running the HausKeys-0.7 application I do
> not require to enter any pin. However, when I tried to run the HausKeys
> build I was prompted for the same. Since I was not able to run the HausKeys
> build using '1234' as pin so I modified the source and used 'secret' as my
> pin value. However, it seems that the TripleSec server uses '1234' as the
> predefined pin value. Am I correct in making such changes?
> It would be of immense help if you could clarify the above and suggest
> ways to run the demo application using an emulator on the Client side.


Hmmmm I think I see what is happening.  Embedded into the midlet is a file
of properties that are used to determine what pin to use to open the
midlet.  Basically Triplesec's provisioning code builds this midlet on the
fly when users register and attempt to download the midlet.  If for some
reason you're emulator does not have these properties available then the
midlet may default to some dummy values.  I wish I can help diagnose the
problem more but I have limited time.

Perhaps you can try first with your phone then we can look into this
problem's cause a little later since running the application from a emulator
I have to know more details of how you built or layed out the classes of the
application etc.

Thanks,
Alex

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message