directory-kerby mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Zheng, Kai" <kai.zh...@intel.com>
Subject RE: Kerby building fails
Date Sat, 04 Jul 2015 05:20:24 GMT
Thanks Kiran.

>> you need latest mavibot build in your local repo
Do we have to rely on this? Maybe we could use some public version? If not then when could
we have the new release version?
I do have the local build of Mavibot, but am not sure all Kerby developers do.

Regards,
Kai

-----Original Message-----
From: Kiran Ayyagari [mailto:kayyagari@apache.org] 
Sent: Saturday, July 04, 2015 1:15 PM
To: kerby@directory.apache.org
Subject: Re: Kerby building fails

On Sat, Jul 4, 2015 at 11:51 AM, Zheng, Kai <kai.zheng@intel.com> wrote:

> Hi Kiran,
>
> It always fails on my side as below. Isn't the artifact already pushed 
> to the public, or should we use any public available one? Thanks.
>
> Regards,
> Kai
>
> [INFO] Kerby Kdc Test .................................... SUCCESS 
> [33.404s] [INFO] Mavibot based backend ............................. 
> FAILURE [0.022s] [INFO] Kerby Distribution 
> ................................ SKIPPED [INFO] KDC Dist 
> .......................................... SKIPPED [INFO] Tool Dist 
> ......................................... SKIPPED [INFO] Kerby 
> benchmark ................................... SKIPPED [INFO]
> ----------------------------------------------------------------------
> --
> [INFO] BUILD FAILURE
> [INFO]
> ----------------------------------------------------------------------
> --
> [INFO] Total time: 3:00.671s
> [INFO] Finished at: Sat Jul 04 11:48:00 CST 2015 [INFO] Final Memory: 
> 54M/335M [INFO]
> ----------------------------------------------------------------------
> -- [ERROR] Failed to execute goal on project mavibot-backend: Could 
> not resolve dependencies for project
> org.apache.kerby:mavibot-backend:jar:1.0-SNAPSHOT: Could not find 
> artifact org .apache.directory.mavibot:mavibot:jar:1.0.0-M8-SNAPSHOT 
> -> [Help 1]
>
you need latest mavibot build in your local repo

> [ERROR]
> [ERROR] To see the full stack trace of the errors, re-run Maven with 
> the -e switch.
> [ERROR] Re-run Maven using the -X switch to enable full debug logging.
> [ERROR]
> [ERROR] For more information about the errors and possible solutions, 
> please read the following articles:
> [ERROR] [Help 1]
> http://cwiki.apache.org/confluence/display/MAVEN/DependencyResolutionE
> xception
> [ERROR]
> [ERROR] After correcting the problems, you can resume the build with 
> the command
> [ERROR]   mvn <goals> -rf :mavibot-backend
>



--
Kiran Ayyagari
http://keydap.com
Mime
View raw message