directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Colm O hEigeartaigh (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (DIRKRB-664) Upgrade Nimbus dependency
Date Thu, 26 Oct 2017 11:48:00 GMT

     [ https://issues.apache.org/jira/browse/DIRKRB-664?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Colm O hEigeartaigh updated DIRKRB-664:
---------------------------------------
    Description: 
This task is to upgrade the Nimbus dependency - we currently ship a very old version.

Migration note: The older Nimbus version automatically installed BouncyCastle, whereas the
current version does not, and so the default encryption method of AES-GCM will fail with the
upgrade if you are using Java 7, unless you manually install BouncyCastle as a security provider.

  was:This task is to upgrade the Nimbus dependency - we currently ship a very old version.


> Upgrade Nimbus dependency
> -------------------------
>
>                 Key: DIRKRB-664
>                 URL: https://issues.apache.org/jira/browse/DIRKRB-664
>             Project: Directory Kerberos
>          Issue Type: Bug
>            Reporter: Colm O hEigeartaigh
>            Assignee: Colm O hEigeartaigh
>             Fix For: 1.1.0
>
>
> This task is to upgrade the Nimbus dependency - we currently ship a very old version.
> Migration note: The older Nimbus version automatically installed BouncyCastle, whereas
the current version does not, and so the default encryption method of AES-GCM will fail with
the upgrade if you are using Java 7, unless you manually install BouncyCastle as a security
provider.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message