directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Josh Anderson (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (DIRSERVER-2178) Unable to install on Mac Sierra 10.12.2
Date Tue, 07 Feb 2017 19:51:41 GMT

    [ https://issues.apache.org/jira/browse/DIRSERVER-2178?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15856643#comment-15856643
] 

Josh Anderson edited comment on DIRSERVER-2178 at 2/7/17 7:51 PM:
------------------------------------------------------------------

I don't know why the installer doesn't work. The actual package contents do seem to work when
you copy them to /usr/bin and /usr/local manually and run `apacheds`.

Since brew puts things in /usr/local/bin that's where I put mine. `apacheds` is a bash script
so you can modify the `INSTALLATION_DIRECTORY` and `INSTANCES_DIRECTORY` to match.

Also running Sierra.

When installing I get this in the console.app

com.apple.message.domain: com.apple.installer.package.preflight.system_content_rejection
com.apple.message.package_version: 2.0.0-M23
com.apple.message.package_identifier: org.apache.directory.server
SenderMachUUID: 3C1CDBAD-6BBE-3D12-ABDA-021CCC00177E




was (Author: fetmar):
I don't know why the installer doesn't work. The actual package contents do seem to work when
you copy them to /usr/bin and /usr/local manually and run `apacheds`.

Since brew puts things in /usr/local/bin that's where I put mine. `apacheds` is a bash script
so you can modify the `INSTALLATION_DIRECTORY` and `INSTANCES_DIRECTORY` to match.

Also running Sierra.

> Unable to install on Mac Sierra 10.12.2
> ---------------------------------------
>
>                 Key: DIRSERVER-2178
>                 URL: https://issues.apache.org/jira/browse/DIRSERVER-2178
>             Project: Directory ApacheDS
>          Issue Type: Bug
>    Affects Versions: 2.0.0-M23
>            Reporter: Adrian Stephen
>         Attachments: Screen Shot 2017-01-05 at 11.55.13 PM.png
>
>
> I am unable to install apacheds . 
> Ill get this error: 
> This package is incompatible with this version of Mac Sierra and may fail to install.
> installing this package may damage your system, and the installation may fail. To stop
the program and the installation, click “Cancel Installation”.
> if I click install anyway, it will fail with the error as the screenshot attached. 



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message