directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stefan Seelmann (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (DIRSTUDIO-1129) Referrals do not work in v2
Date Fri, 11 Nov 2016 22:44:58 GMT

    [ https://issues.apache.org/jira/browse/DIRSTUDIO-1129?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15658399#comment-15658399
] 

Stefan Seelmann edited comment on DIRSTUDIO-1129 at 11/11/16 10:44 PM:
-----------------------------------------------------------------------

I just checked, referral handling for write operations is not implemented in "Apache Directory
LDAP API provider", only search continuations work. Can you please try to switch to JNDI connection
provider (Connection properties -> Network tab -> Provider)?



was (Author: seelmann):
I just check, referral handling for write operations is not implemented in "Apache Directory
LDAP API provider", only search continuations work. Can you please try to switch to JNDI connection
provider (Connection properties -> Network tab -> Provider)?


> Referrals do not work in v2
> ---------------------------
>
>                 Key: DIRSTUDIO-1129
>                 URL: https://issues.apache.org/jira/browse/DIRSTUDIO-1129
>             Project: Directory Studio
>          Issue Type: Bug
>    Affects Versions: 2.0.0-M9 (2.0.0.v20150606-M9), 2.0.0-M12
>         Environment: [pv@LON-IX-L-763 ~]$ lsb_release -a
> No LSB modules are available.
> Distributor ID:	Ubuntu
> Description:	Ubuntu 15.10
> Release:	15.10
> Codename:	wily
> [pv@LON-IX-L-763 ~]$ uname -a
> Linux LON-IX-L-763 4.2.0-42-generic #49-Ubuntu SMP Tue Jun 28 21:26:26 UTC 2016 x86_64
x86_64 x86_64 GNU/Linux
>            Reporter: Patrick van Staveren
>            Priority: Minor
>
> I've been using Apache Directory Studio with referrals for a long time, but it seems
that they've broken from v1.5.4 -> v2.  I've validated this behavior against v2.0.0-M9
and v2.0.0-M12.
> I get this when trying to do any create / modify / delete action after I've been connected.
 I have many LDAP slaves which all refer to a single master, and I have a profile the read-only
slaves and for the single write master.
> On version 1.5.4, using the exact same servers and connection settings, I get a popup
dialog box when trying to make a chance which lets me select the referral server.  I select
my write server, and it works.
> When I try to create a new entry or make a modification, I get this stack trace:
> Error while creating entry
>  - [LDAP: error code 10 - Referral]
>   java.lang.Exception: [LDAP: error code 10 - Referral]
> 	at org.apache.directory.studio.connection.core.io.api.DirectoryApiConnectionWrapper.checkResponse(DirectoryApiConnectionWrapper.java:1268)
> 	at org.apache.directory.studio.connection.core.io.api.DirectoryApiConnectionWrapper.access$9(DirectoryApiConnectionWrapper.java:1236)
> 	at org.apache.directory.studio.connection.core.io.api.DirectoryApiConnectionWrapper$6.run(DirectoryApiConnectionWrapper.java:918)
> 	at org.apache.directory.studio.connection.core.io.api.DirectoryApiConnectionWrapper.runAndMonitor(DirectoryApiConnectionWrapper.java:1163)
> 	at org.apache.directory.studio.connection.core.io.api.DirectoryApiConnectionWrapper.checkConnectionAndRunAndMonitor(DirectoryApiConnectionWrapper.java:1099)
> 	at org.apache.directory.studio.connection.core.io.api.DirectoryApiConnectionWrapper.createEntry(DirectoryApiConnectionWrapper.java:940)
> 	at org.apache.directory.studio.ldapbrowser.core.jobs.CreateEntryRunnable.createEntry(CreateEntryRunnable.java:225)
> 	at org.apache.directory.studio.ldapbrowser.core.jobs.CreateEntryRunnable.run(CreateEntryRunnable.java:124)
> 	at org.apache.directory.studio.connection.ui.RunnableContextRunner$1.run(RunnableContextRunner.java:116)
> 	at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:119)
>   [LDAP: error code 10 - Referral]
> I've tried this with all three settings in Connection Settings -> Browser Options
-> Referral Handling and it doesn't seem to have any effect.  Is there anything else I
can try to get this working, or any further debug information I can supply?  I control the
LDAP servers as well so it's easy for me to share information from that side as well.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message