directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Winder (JIRA)" <j...@apache.org>
Subject [jira] [Created] (DIRSTUDIO-1099) Unable to launch Apache Directory Studio
Date Thu, 10 Mar 2016 14:44:40 GMT
Michael Winder created DIRSTUDIO-1099:
-----------------------------------------

             Summary: Unable to launch Apache Directory Studio
                 Key: DIRSTUDIO-1099
                 URL: https://issues.apache.org/jira/browse/DIRSTUDIO-1099
             Project: Directory Studio
          Issue Type: IT Help
          Components: studio-apacheds
    Affects Versions: 2.0.0-M8 (2.0.0.v20130628)
         Environment: Windows 7 Enterprise SP1 on a 64-bit machine, Java version is 1.8.0_71.
            Reporter: Michael Winder
            Priority: Minor


I have installed this version of ADS onto my work PC but whenever I launch it from either
the option in the Start menu or from 'All Programs' a dialogue is displayed with the message
"An error has occurred. See the log file C:\Program Files (x86)\Apache Directory Studio\configuration\1455100848190.log"
(the log file name is unique and different every time).

The information in the log file however is the same every time, i.e.

!SESSION 2016-02-10 10:40:46.926 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.8.0_71
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_GB
Command-line arguments:  -os win32 -ws win32 -arch x86

!ENTRY org.eclipse.osgi 4 0 2016-02-10 10:40:54.040
!MESSAGE Application error
!STACK 1
java.lang.NoClassDefFoundError: com/mercury/javashared/agentloader/AgentBootstrap
	at org.eclipse.swt.widgets.Display.<init>(Display.java:480)
	at org.eclipse.ui.internal.Workbench.createDisplay(Workbench.java:716)
	at org.eclipse.ui.PlatformUI.createDisplay(PlatformUI.java:161)
	at org.apache.directory.studio.Application.start(Application.java:47)
	at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:353)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:180)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
	at java.lang.reflect.Method.invoke(Unknown Source)
	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:629)
	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:584)
	at org.eclipse.equinox.launcher.Main.run(Main.java:1438)
Caused by: java.lang.ClassNotFoundException: com.mercury.javashared.agentloader.AgentBootstrap
	at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:501)
	at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:421)
	at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:412)
	at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:107)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	... 16 more 

My employer's IT Helpdesk have been looking into this for 2 months but have not been able
to resolve the issue so any assistance/advice/suggestions you can provide would be most welcome.

Thank you.




--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message