directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Seelmann <m...@stefan-seelmann.de>
Subject Re: commons.io removal and Studio
Date Sat, 27 Feb 2016 10:11:39 GMT
On 02/27/2016 10:55 AM, Emmanuel L├ęcharny wrote:
> Hi Stefan
> 
> I have completely removed commons.io from the LDAP API and ApacheDS? and
> I'm now trying to do the same in Studio. It's a bit harder :-)
> 
> First, I removed any dependency on commons.io in all the pom files, then
> I rebuilt the project (I faced some issues because the java files
> weren't fixed, but that should be easy to fix).
> 
> Nw, when I load the project sin Mars, the places where I used
> org.apache.directory.pi.util.FileUtils aren't seing this class. When I
> check the .m2 repository (which I doomed before building everytjing, so

Normally it's only required to delete ~/.m2/repository/p2

> it was blanck), I see that I have 2 versions of the ldap-util jar :
> 1.0.0-M33 and 1.0.0-M34-SNAPSHOT. Obviously, the error I see are due to
> the presence of this 1.0.0-M33 depencency, but I don't see where it
> pulls it from...

Where do you see the two jars?
* In folder eclipse-trgt-platform/target/repository/plugins/ ?
* Within Eclipse in the project dependencies ?

In the 2nd case - did you re-initialize the target platform in Eclipse?
* Open the org.apache.directory.studio.eclipse-trgt-platform.target file
* Wait till the dependencies are resolved
* In the top right corner click 'Set as Target Platform'



Mime
View raw message