directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Martin Franz (JIRA)" <>
Subject [jira] [Commented] (DIRSERVER-2111) Copy / Paste of Object fails due to ERROR ENTRY_ALREADY_EXISTS Error
Date Thu, 14 Jan 2016 08:59:39 GMT


Martin Franz commented on DIRSERVER-2111:

What I tried:
Restart Studio as well as ApacheDS.
After that the entry was still not visible and I was still not able to create it. 

After that I thought the entry perhaps hangs somewhere in cache. So I deleted the cache folder
- restarted everything - but still the same behavior. 

My thoughts: This currently happens just with two items in whole DS. I remember that when
I try to create the entry the first time it fails due to connection error. After a reconnect
the problem with this item starts (It was not visible but I can't create it)
Is there any way to repair or look into the partions "raw" data server side? (Like the master.db)
There must be a index somewhere. 

I attached some screenshots which show the copy / paste process. 

> Copy / Paste of Object fails due to ERROR ENTRY_ALREADY_EXISTS Error
> --------------------------------------------------------------------
>                 Key: DIRSERVER-2111
>                 URL:
>             Project: Directory ApacheDS
>          Issue Type: Test
>    Affects Versions: 2.0.0-M20
>         Environment: Directory runs on: Ubuntu 14.04.2 LTS
> Directory Studio runs on Mac
>            Reporter: Martin Franz
>            Priority: Minor
>              Labels: documentation
>         Attachments: Bildschirmfoto 2016-01-14 um 09.31.01.png, Bildschirmfoto 2016-01-14
um 09.31.23.png, Bildschirmfoto 2016-01-14 um 09.31.34.png, Bildschirmfoto 2016-01-14 um 09.31.48.png,
Bildschirmfoto 2016-01-14 um 09.32.11.png, Bildschirmfoto 2016-01-14 um 09.32.29.png, Bildschirmfoto
2016-01-14 um 09.32.58.png
> This happens only sometimes!
> 1. Copy an Object DN 
> 2. Past it to the parent 
> 3. Rename it 
> 4. While saving something goes wrong with connection for example / force a tree refresh
/ newly created item is NOT visible in the tree.
> 5. Repeat step 1 - 3
> 6. Error: entry already exists but the item is definitely not a member of the tree.
> I did not found any way to fix this. Even after removing the cache. No way. 

This message was sent by Atlassian JIRA

View raw message