directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Emmanuel Lecharny (JIRA)" <>
Subject [jira] [Commented] (DIRSTUDIO-1078) unable to use # pound hash sign in LDAP filters
Date Wed, 09 Dec 2015 11:41:10 GMT


Emmanuel Lecharny commented on DIRSTUDIO-1078:

Your example is just considering a 'pure' DN. I'm talking about a DN 'inside' a filter, thus
the double escaping...

Also a # *inside* a value in a DN is not a problem. The same '#' at the first position of
a value in a DN is a different story, as it *has* to be escaped, per the {{leadchar}} rule

> unable to use # pound hash sign in LDAP filters
> -----------------------------------------------
>                 Key: DIRSTUDIO-1078
>                 URL:
>             Project: Directory Studio
>          Issue Type: Bug
>    Affects Versions: 2.0.0-M9 (2.0.0.v20150606-M9)
>            Reporter: Sorin Sbarnea
> It seems impossible to perform searches that to use # sign inside. Tried to add them,
not escaped, escaped with single or double backslash but none of these approaches worked.

> Example
> {code}
> (&(objectClass=group)(displayName=*)(|(memberOf:1.2.840.113556.1.4.1941:=CN=\\#SOME,OU=Groups,OU=EMEA,DC=example,DC=net)))
> (&(objectClass=group)(displayName=*)(|(memberOf:1.2.840.113556.1.4.1941:=CN=\#SOME,OU=Groups,OU=EMEA,DC=example,DC=net)))
> (&(objectClass=group)(displayName=*)(|(memberOf:1.2.840.113556.1.4.1941:=CN=#SOME,OU=Groups,OU=EMEA,DC=example,DC=net)))
> {code}

This message was sent by Atlassian JIRA

View raw message