directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Emmanuel Lecharny (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (DIRSTUDIO-1070) Can't start on OS X using Java8
Date Mon, 05 Oct 2015 05:31:26 GMT

    [ https://issues.apache.org/jira/browse/DIRSTUDIO-1070?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14942945#comment-14942945
] 

Emmanuel Lecharny commented on DIRSTUDIO-1070:
----------------------------------------------

And when I launch Studio after this config modification, here are the logs I get (and Studio
exits) :

{noformat}
!SESSION 2015-10-05 07:25:28.642 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.6.0_65
java.vendor=Apple Inc.
BootLoader constants: OS=macosx, ARCH=x86_64, WS=cocoa, NL=en_US
Framework arguments:  /studio-rcp/resources/icons/linux/studio.xpm -keyring /Users/elecharny/.eclipse_keyring
-showlocation
Command-line arguments:  -os macosx -ws cocoa -arch x86_64 /studio-rcp/resources/icons/linux/studio.xpm
-keyring /Users/elecharny/.eclipse_keyring -showlocation

!ENTRY org.apache.directory.studio.apacheds.configuration 4 0 2015-10-05 07:25:29.505
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.apache.directory.studio.apacheds.configuration
[52]
  Unresolved requirement: Require-Bundle: org.apache.directory.server.config; bundle-version="2.0.0.M20"
    -> Bundle-SymbolicName: org.apache.directory.server.config; bundle-version="2.0.0.M20"
       org.apache.directory.server.config [43]
         Unresolved requirement: Import-Package: org.apache.directory.server.core.api; version="[2.0.0,3.0.0)"
           -> Export-Package: org.apache.directory.server.core.api; bundle-version="2.0.0.M20";
bundle-symbolic-name="org.apache.directory.server.core.api"; version="2.0.0"; uses:="net.sf.ehcache,org.apache.directory.api.asn1.util,org.apache.directory.api.ldap.codec.api,org.apache.directory.api.ldap.model.constants,org.apache.directory.api.ldap.model.csn,org.apache.directory.api.ldap.model.cursor,org.apache.directory.api.ldap.model.entry,org.apache.directory.api.ldap.model.exception,org.apache.directory.api.ldap.model.filter,org.apache.directory.api.ldap.model.ldif,org.apache.directory.api.ldap.model.message,org.apache.directory.api.ldap.model.name,org.apache.directory.api.ldap.model.schema,org.apache.directory.api.ldap.util.tree,org.apache.directory.ldap.client.api,org.apache.directory.server.core.api.administrative,org.apache.directory.server.core.api.changelog,org.apache.directory.server.core.api.entry,org.apache.directory.server.core.api.event,org.apache.directory.server.core.api.filtering,org.apache.directory.server.core.api.interceptor,org.apache.directory.server.core.api.interceptor.context,org.apache.directory.server.core.api.journal,org.apache.directory.server.core.api.partition,org.apache.directory.server.core.api.schema,org.apache.directory.server.core.api.subtree,org.slf4j"
              org.apache.directory.server.core.api [44]
                Unresolved requirement: Import-Package: org.apache.directory.server.i18n;
version="[2.0.0,3.0.0)"
                  -> Export-Package: org.apache.directory.server.i18n; bundle-version="2.0.0.M20";
bundle-symbolic-name="org.apache.directory.server.i18n"; version="2.0.0.M20"
                     org.apache.directory.server.i18n [47]
                       Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"

        at org.eclipse.osgi.container.Module.start(Module.java:434)
        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
        at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
        at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.apache.directory.studio.ldapservers.apacheds 4 0 2015-10-05 07:25:29.514
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.apache.directory.studio.ldapservers.apacheds
[63]
  Unresolved requirement: Require-Bundle: org.apache.directory.server.config; bundle-version="2.0.0.M20"
    -> Bundle-SymbolicName: org.apache.directory.server.config; bundle-version="2.0.0.M20"
       org.apache.directory.server.config [43]
         Unresolved requirement: Import-Package: org.apache.directory.server.core.api; version="[2.0.0,3.0.0)"
           -> Export-Package: org.apache.directory.server.core.api; bundle-version="2.0.0.M20";
bundle-symbolic-name="org.apache.directory.server.core.api"; version="2.0.0"; uses:="net.sf.ehcache,org.apache.directory.api.asn1.util,org.apache.directory.api.ldap.codec.api,org.apache.directory.api.ldap.model.constants,org.apache.directory.api.ldap.model.csn,org.apache.directory.api.ldap.model.cursor,org.apache.directory.api.ldap.model.entry,org.apache.directory.api.ldap.model.exception,org.apache.directory.api.ldap.model.filter,org.apache.directory.api.ldap.model.ldif,org.apache.directory.api.ldap.model.message,org.apache.directory.api.ldap.model.name,org.apache.directory.api.ldap.model.schema,org.apache.directory.api.ldap.util.tree,org.apache.directory.ldap.client.api,org.apache.directory.server.core.api.administrative,org.apache.directory.server.core.api.changelog,org.apache.directory.server.core.api.entry,org.apache.directory.server.core.api.event,org.apache.directory.server.core.api.filtering,org.apache.directory.server.core.api.interceptor,org.apache.directory.server.core.api.interceptor.context,org.apache.directory.server.core.api.journal,org.apache.directory.server.core.api.partition,org.apache.directory.server.core.api.schema,org.apache.directory.server.core.api.subtree,org.slf4j"
              org.apache.directory.server.core.api [44]
                Unresolved requirement: Import-Package: org.apache.directory.server.i18n;
version="[2.0.0,3.0.0)"
                  -> Export-Package: org.apache.directory.server.i18n; bundle-version="2.0.0.M20";
bundle-symbolic-name="org.apache.directory.server.i18n"; version="2.0.0.M20"
                     org.apache.directory.server.i18n [47]
                       Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"

        at org.eclipse.osgi.container.Module.start(Module.java:434)
        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
        at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
        at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.apache.directory.server.xdbm.partition 2 0 2015-10-05 07:25:29.882
!MESSAGE Could not resolve module: org.apache.directory.server.xdbm.partition [50]
  Unresolved requirement: Import-Package: org.apache.directory.server.core.api; version="[2.0.0,3.0.0)"
    -> Export-Package: org.apache.directory.server.core.api; bundle-version="2.0.0.M20";
bundle-symbolic-name="org.apache.directory.server.core.api"; version="2.0.0"; uses:="net.sf.ehcache,org.apache.directory.api.asn1.util,org.apache.directory.api.ldap.codec.api,org.apache.directory.api.ldap.model.constants,org.apache.directory.api.ldap.model.csn,org.apache.directory.api.ldap.model.cursor,org.apache.directory.api.ldap.model.entry,org.apache.directory.api.ldap.model.exception,org.apache.directory.api.ldap.model.filter,org.apache.directory.api.ldap.model.ldif,org.apache.directory.api.ldap.model.message,org.apache.directory.api.ldap.model.name,org.apache.directory.api.ldap.model.schema,org.apache.directory.api.ldap.util.tree,org.apache.directory.ldap.client.api,org.apache.directory.server.core.api.administrative,org.apache.directory.server.core.api.changelog,org.apache.directory.server.core.api.entry,org.apache.directory.server.core.api.event,org.apache.directory.server.core.api.filtering,org.apache.directory.server.core.api.interceptor,org.apache.directory.server.core.api.interceptor.context,org.apache.directory.server.core.api.journal,org.apache.directory.server.core.api.partition,org.apache.directory.server.core.api.schema,org.apache.directory.server.core.api.subtree,org.slf4j"
       org.apache.directory.server.core.api [44]
         Unresolved requirement: Import-Package: org.apache.directory.server.i18n; version="[2.0.0,3.0.0)"
           -> Export-Package: org.apache.directory.server.i18n; bundle-version="2.0.0.M20";
bundle-symbolic-name="org.apache.directory.server.i18n"; version="2.0.0.M20"
              org.apache.directory.server.i18n [47]
                Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"


!ENTRY org.apache.directory.server.config 2 0 2015-10-05 07:25:29.883
!MESSAGE Could not resolve module: org.apache.directory.server.config [43]
  Unresolved requirement: Import-Package: org.apache.directory.server.core.api; version="[2.0.0,3.0.0)"
    -> Export-Package: org.apache.directory.server.core.api; bundle-version="2.0.0.M20";
bundle-symbolic-name="org.apache.directory.server.core.api"; version="2.0.0"; uses:="net.sf.ehcache,org.apache.directory.api.asn1.util,org.apache.directory.api.ldap.codec.api,org.apache.directory.api.ldap.model.constants,org.apache.directory.api.ldap.model.csn,org.apache.directory.api.ldap.model.cursor,org.apache.directory.api.ldap.model.entry,org.apache.directory.api.ldap.model.exception,org.apache.directory.api.ldap.model.filter,org.apache.directory.api.ldap.model.ldif,org.apache.directory.api.ldap.model.message,org.apache.directory.api.ldap.model.name,org.apache.directory.api.ldap.model.schema,org.apache.directory.api.ldap.util.tree,org.apache.directory.ldap.client.api,org.apache.directory.server.core.api.administrative,org.apache.directory.server.core.api.changelog,org.apache.directory.server.core.api.entry,org.apache.directory.server.core.api.event,org.apache.directory.server.core.api.filtering,org.apache.directory.server.core.api.interceptor,org.apache.directory.server.core.api.interceptor.context,org.apache.directory.server.core.api.journal,org.apache.directory.server.core.api.partition,org.apache.directory.server.core.api.schema,org.apache.directory.server.core.api.subtree,org.slf4j"
       org.apache.directory.server.core.api [44]
         Unresolved requirement: Import-Package: org.apache.directory.server.i18n; version="[2.0.0,3.0.0)"
           -> Export-Package: org.apache.directory.server.i18n; bundle-version="2.0.0.M20";
bundle-symbolic-name="org.apache.directory.server.i18n"; version="2.0.0.M20"
              org.apache.directory.server.i18n [47]
                Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"


!ENTRY org.apache.directory.studio.apacheds.configuration 2 0 2015-10-05 07:25:29.883
!MESSAGE Could not resolve module: org.apache.directory.studio.apacheds.configuration [52]
  Unresolved requirement: Require-Bundle: org.apache.directory.server.config; bundle-version="2.0.0.M20"
    -> Bundle-SymbolicName: org.apache.directory.server.config; bundle-version="2.0.0.M20"
       org.apache.directory.server.config [43]
         Unresolved requirement: Import-Package: org.apache.directory.server.core.api; version="[2.0.0,3.0.0)"
           -> Export-Package: org.apache.directory.server.core.api; bundle-version="2.0.0.M20";
bundle-symbolic-name="org.apache.directory.server.core.api"; version="2.0.0"; uses:="net.sf.ehcache,org.apache.directory.api.asn1.util,org.apache.directory.api.ldap.codec.api,org.apache.directory.api.ldap.model.constants,org.apache.directory.api.ldap.model.csn,org.apache.directory.api.ldap.model.cursor,org.apache.directory.api.ldap.model.entry,org.apache.directory.api.ldap.model.exception,org.apache.directory.api.ldap.model.filter,org.apache.directory.api.ldap.model.ldif,org.apache.directory.api.ldap.model.message,org.apache.directory.api.ldap.model.name,org.apache.directory.api.ldap.model.schema,org.apache.directory.api.ldap.util.tree,org.apache.directory.ldap.client.api,org.apache.directory.server.core.api.administrative,org.apache.directory.server.core.api.changelog,org.apache.directory.server.core.api.entry,org.apache.directory.server.core.api.event,org.apache.directory.server.core.api.filtering,org.apache.directory.server.core.api.interceptor,org.apache.directory.server.core.api.interceptor.context,org.apache.directory.server.core.api.journal,org.apache.directory.server.core.api.partition,org.apache.directory.server.core.api.schema,org.apache.directory.server.core.api.subtree,org.slf4j"
              org.apache.directory.server.core.api [44]
                Unresolved requirement: Import-Package: org.apache.directory.server.i18n;
version="[2.0.0,3.0.0)"
                  -> Export-Package: org.apache.directory.server.i18n; bundle-version="2.0.0.M20";
bundle-symbolic-name="org.apache.directory.server.i18n"; version="2.0.0.M20"
                     org.apache.directory.server.i18n [47]
                       Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"


!ENTRY org.eclipse.core.filesystem.java7 2 0 2015-10-05 07:25:29.883
!MESSAGE Could not resolve module: org.eclipse.core.filesystem.java7 [118]
  Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"
  Unresolved requirement: Fragment-Host: org.eclipse.core.filesystem; bundle-version="[1.4.100,2.0.0)"


!ENTRY org.apache.directory.server.ldif.partition 2 0 2015-10-05 07:25:29.883
!MESSAGE Could not resolve module: org.apache.directory.server.ldif.partition [49]
  Unresolved requirement: Import-Package: org.apache.directory.server.core.api; version="[2.0.0,3.0.0)"
    -> Export-Package: org.apache.directory.server.core.api; bundle-version="2.0.0.M20";
bundle-symbolic-name="org.apache.directory.server.core.api"; version="2.0.0"; uses:="net.sf.ehcache,org.apache.directory.api.asn1.util,org.apache.directory.api.ldap.codec.api,org.apache.directory.api.ldap.model.constants,org.apache.directory.api.ldap.model.csn,org.apache.directory.api.ldap.model.cursor,org.apache.directory.api.ldap.model.entry,org.apache.directory.api.ldap.model.exception,org.apache.directory.api.ldap.model.filter,org.apache.directory.api.ldap.model.ldif,org.apache.directory.api.ldap.model.message,org.apache.directory.api.ldap.model.name,org.apache.directory.api.ldap.model.schema,org.apache.directory.api.ldap.util.tree,org.apache.directory.ldap.client.api,org.apache.directory.server.core.api.administrative,org.apache.directory.server.core.api.changelog,org.apache.directory.server.core.api.entry,org.apache.directory.server.core.api.event,org.apache.directory.server.core.api.filtering,org.apache.directory.server.core.api.interceptor,org.apache.directory.server.core.api.interceptor.context,org.apache.directory.server.core.api.journal,org.apache.directory.server.core.api.partition,org.apache.directory.server.core.api.schema,org.apache.directory.server.core.api.subtree,org.slf4j"
       org.apache.directory.server.core.api [44]
         Unresolved requirement: Import-Package: org.apache.directory.server.i18n; version="[2.0.0,3.0.0)"
           -> Export-Package: org.apache.directory.server.i18n; bundle-version="2.0.0.M20";
bundle-symbolic-name="org.apache.directory.server.i18n"; version="2.0.0.M20"
              org.apache.directory.server.i18n [47]
                Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"


!ENTRY org.apache.directory.server.core.api 2 0 2015-10-05 07:25:29.884
!MESSAGE Could not resolve module: org.apache.directory.server.core.api [44]
  Unresolved requirement: Import-Package: org.apache.directory.server.i18n; version="[2.0.0,3.0.0)"
    -> Export-Package: org.apache.directory.server.i18n; bundle-version="2.0.0.M20"; bundle-symbolic-name="org.apache.directory.server.i18n";
version="2.0.0.M20"
       org.apache.directory.server.i18n [47]
         Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"


!ENTRY org.apache.directory.server.core.avl 2 0 2015-10-05 07:25:29.884
!MESSAGE Could not resolve module: org.apache.directory.server.core.avl [45]
  Unresolved requirement: Import-Package: org.apache.directory.server.i18n; version="[2.0.0,3.0.0)"
    -> Export-Package: org.apache.directory.server.i18n; bundle-version="2.0.0.M20"; bundle-symbolic-name="org.apache.directory.server.i18n";
version="2.0.0.M20"
       org.apache.directory.server.i18n [47]
         Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"


!ENTRY org.apache.directory.server.kerberos.codec 2 0 2015-10-05 07:25:29.884
!MESSAGE Could not resolve module: org.apache.directory.server.kerberos.codec [48]
  Unresolved requirement: Import-Package: org.apache.directory.server.i18n; version="[2.0.0,3.0.0)"
    -> Export-Package: org.apache.directory.server.i18n; bundle-version="2.0.0.M20"; bundle-symbolic-name="org.apache.directory.server.i18n";
version="2.0.0.M20"
       org.apache.directory.server.i18n [47]
         Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"


!ENTRY org.apache.directory.server.i18n 2 0 2015-10-05 07:25:29.884
!MESSAGE Could not resolve module: org.apache.directory.server.i18n [47]
  Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"


!ENTRY org.apache.directory.server.core.constants 2 0 2015-10-05 07:25:29.884
!MESSAGE Could not resolve module: org.apache.directory.server.core.constants [46]
  Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"


!ENTRY org.apache.directory.studio.ldapservers.apacheds 2 0 2015-10-05 07:25:29.884
!MESSAGE Could not resolve module: org.apache.directory.studio.ldapservers.apacheds [63]
  Unresolved requirement: Require-Bundle: org.apache.directory.server.config; bundle-version="2.0.0.M20"
    -> Bundle-SymbolicName: org.apache.directory.server.config; bundle-version="2.0.0.M20"
       org.apache.directory.server.config [43]
         Unresolved requirement: Import-Package: org.apache.directory.server.core.api; version="[2.0.0,3.0.0)"
           -> Export-Package: org.apache.directory.server.core.api; bundle-version="2.0.0.M20";
bundle-symbolic-name="org.apache.directory.server.core.api"; version="2.0.0"; uses:="net.sf.ehcache,org.apache.directory.api.asn1.util,org.apache.directory.api.ldap.codec.api,org.apache.directory.api.ldap.model.constants,org.apache.directory.api.ldap.model.csn,org.apache.directory.api.ldap.model.cursor,org.apache.directory.api.ldap.model.entry,org.apache.directory.api.ldap.model.exception,org.apache.directory.api.ldap.model.filter,org.apache.directory.api.ldap.model.ldif,org.apache.directory.api.ldap.model.message,org.apache.directory.api.ldap.model.name,org.apache.directory.api.ldap.model.schema,org.apache.directory.api.ldap.util.tree,org.apache.directory.ldap.client.api,org.apache.directory.server.core.api.administrative,org.apache.directory.server.core.api.changelog,org.apache.directory.server.core.api.entry,org.apache.directory.server.core.api.event,org.apache.directory.server.core.api.filtering,org.apache.directory.server.core.api.interceptor,org.apache.directory.server.core.api.interceptor.context,org.apache.directory.server.core.api.journal,org.apache.directory.server.core.api.partition,org.apache.directory.server.core.api.schema,org.apache.directory.server.core.api.subtree,org.slf4j"
              org.apache.directory.server.core.api [44]
                Unresolved requirement: Import-Package: org.apache.directory.server.i18n;
version="[2.0.0,3.0.0)"
                  -> Export-Package: org.apache.directory.server.i18n; bundle-version="2.0.0.M20";
bundle-symbolic-name="org.apache.directory.server.i18n"; version="2.0.0.M20"
                     org.apache.directory.server.i18n [47]
                       Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"


!ENTRY org.eclipse.osgi 4 0 2015-10-05 07:25:30.111
!MESSAGE Application error
!STACK 1
org.eclipse.core.runtime.CoreException: Plug-in org.apache.directory.studio.rcp was unable
to load class org.apache.directory.studio.Application.
        at org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI.throwException(RegistryStrategyOSGI.java:194)
        at org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI.createExecutableExtension(RegistryStrategyOSGI.java:178)
        at org.eclipse.core.internal.registry.ExtensionRegistry.createExecutableExtension(ExtensionRegistry.java:905)
        at org.eclipse.core.internal.registry.ConfigurationElement.createExecutableExtension(ConfigurationElement.java:243)
        at org.eclipse.core.internal.registry.ConfigurationElementHandle.createExecutableExtension(ConfigurationElementHandle.java:55)
        at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:191)
        at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
        at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
        at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:380)
        at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:235)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:648)
        at org.eclipse.equinox.launcher.Main.basicRun(Main.java:603)
        at org.eclipse.equinox.launcher.Main.run(Main.java:1465)
Caused by: java.lang.UnsupportedClassVersionError: org/apache/directory/studio/Application
: Unsupported major.minor version 51.0
        at java.lang.ClassLoader.defineClass1(Native Method)
        at java.lang.ClassLoader.defineClassCond(ClassLoader.java:637)
        at java.lang.ClassLoader.defineClass(ClassLoader.java:621)
        at org.eclipse.osgi.internal.loader.ModuleClassLoader.defineClass(ModuleClassLoader.java:285)
        at org.eclipse.osgi.internal.loader.classpath.ClasspathManager.defineClass(ClasspathManager.java:632)
        at org.eclipse.osgi.internal.loader.classpath.ClasspathManager.findClassImpl(ClasspathManager.java:588)
        at org.eclipse.osgi.internal.loader.classpath.ClasspathManager.findLocalClassImpl(ClasspathManager.java:540)
        at org.eclipse.osgi.internal.loader.classpath.ClasspathManager.findLocalClass(ClasspathManager.java:527)
        at org.eclipse.osgi.internal.loader.ModuleClassLoader.findLocalClass(ModuleClassLoader.java:324)
        at org.eclipse.osgi.internal.loader.BundleLoader.findLocalClass(BundleLoader.java:320)
        at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:395)
        at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:345)
        at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:337)
        at org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass(ModuleClassLoader.java:160)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
        at org.eclipse.osgi.internal.framework.EquinoxBundle.loadClass(EquinoxBundle.java:568)
        at org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI.createExecutableExtension(RegistryStrategyOSGI.java:174)
        ... 15 more
{noformat}

Seems like Java 7 is required, and seems like it still founds Java 6...

> Can't start on OS X using Java8
> -------------------------------
>
>                 Key: DIRSTUDIO-1070
>                 URL: https://issues.apache.org/jira/browse/DIRSTUDIO-1070
>             Project: Directory Studio
>          Issue Type: Bug
>    Affects Versions: 2.0.0-M9 (2.0.0.v20150606-M9)
>         Environment: OSX 10.10
> Installed JavaSE, JavaSDK
>            Reporter: Florian Heigl
>            Priority: Blocker
>
> Well it won't even run without installing a old Java6 SDK.
> That would be problematic since DS Studio is what I use for maintaining the really critical
stuff, so I would prefer to not get attacked anywhere I go by having old Java crud installed.
> It seems it would mostly be a matter of modifying the plist file.
> The DS FAQ has some info about setting the java version but OS X is not mentioned in
those howtos.
> I'm going to try poking at the file, but most probably i'll fail and just sit there and
sob.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message