directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aaron Burgemeister (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (DIRSTUDIO-1061) RawSchemaDefinition always shows single hyphen/dash (empty) for attributes or classes
Date Thu, 02 Jul 2015 02:55:04 GMT

    [ https://issues.apache.org/jira/browse/DIRSTUDIO-1061?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14611378#comment-14611378
] 

Aaron Burgemeister commented on DIRSTUDIO-1061:
-----------------------------------------------

Stefan,

Thank-you for the quick answers.

The nightly build resolves the issue satisfactorily, though there is a new issue when going
into the Schema Browser.  Specifically, when opening the Schema Browser everything looks fine
until you click on one of the listed classes (it always opens to the Classes tab so far) and
nothing happens.  Trying to close the Schema Browser also does not work (seems unresponsive
all around) but if I click on any other tab in the Schema Browser (Attributes, Syntaxes, etc.)
it seems to come back to life, and from then on everything works, including going back to
the Classes tab.  Per the original bug report, once I can click on a class, attribute, or
otherwise, I can see the RawSchemaDefinition as expected by clicking on that to expand it,
so that is wonderful.  I would report this other issue as a new bug, but being the 20150701
nightly build I'm not sure I should do that.  Also, the Schema Browser is much slower than
the current M9 build's, but again this is a nightly and who knows how many changes are in
the works, optimizations left out for a final build, etc.  If you would like a new bug report
for the Schema Browser symptom described above, please confirm and I'll open that for you.

Unit tests, understandable.  The fixed line (just a few characters, as seems to be the case
most of the time) looks so simple, and I'm glad I didn't pursue this as I never would have
worked that out so well.  The tests I will trust work; it looks like one of the files checks
to match a regex that a raw schema definition has 'NAME' somewhere in it, which is a safe
assumption for every class and attribute raw schema definition in existence I think, so that
makes sense.

Thanks for everything.

> RawSchemaDefinition always shows single hyphen/dash (empty) for attributes or classes
> -------------------------------------------------------------------------------------
>
>                 Key: DIRSTUDIO-1061
>                 URL: https://issues.apache.org/jira/browse/DIRSTUDIO-1061
>             Project: Directory Studio
>          Issue Type: Bug
>          Components: studio-schemaeditor
>    Affects Versions: 2.0.0-M9 (2.0.0.v20150606-M9)
>         Environment: openSUSE 13.1 x86_64
> NetIQ eDirectory 8.8 SP8 backend
> OpenLDAP backend
> ApacheDS 2.0.0 (within Apache Directory Studio)
>            Reporter: Aaron Burgemeister
>            Assignee: Stefan Seelmann
>             Fix For: 2.0.0-M10
>
>
> A part of Apache Directory Studio I use a fair bit is the view of the RawSchemaDefinition
within the Schema Editor.  Attempting to use this in M9 (where I'm 99.99% sure it worked in
M8, or whatever the previous public milestone was from 2013) yields nothing but the hyphen/dash
that indicates nothing is there.
> Steps to duplicate:
> Point to a directory (ldap.forumsys.com:389 is public and duplicates the problem)
> Click on Root DSE
> LDAP (menu): Open Schema Editor
> Click on any class or attribute and attempt to get information when expanding the RawSchemaDefinition
field.
> Expected Results: Show the raw schema definition.
> Actual Results: No raw schema definition anymore.
> Reproducible: Always
> I pointed to three different types of servers in case something was amiss with one of
their schema representations, but all of them exhibit the same symptom, including the built-in
ApacheDS instance that I created anew in Studio M9.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message