directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Emmanuel L├ęcharny <elecha...@gmail.com>
Subject [Studio] Difficulties with API M31
Date Mon, 06 Jul 2015 14:39:45 GMT
Hi,

as usual, I'm facing some issues after having bumped up a dependency
(here, it's LDAP API 1.0.0-M31). Here is the error I get :

localhost:studio elecharny$ mvn clean install
Java HotSpot(TM) 64-Bit Server VM warning: ignoring option
MaxPermSize=256M; support was removed in 8.0
[INFO] Scanning for projects...
[INFO] Computing target platform for MavenProject:
org.apache.directory.studio:org.apache.directory.studio.aciitemeditor:2.0.0-SNAPSHOT
@ /Users/elecharny/apacheds/studio/plugins/aciitemeditor/pom.xml
[INFO] Adding repository
file:///Users/elecharny/apacheds/studio/eclipse-trgt-platform/target/repository
[INFO] Fetching p2.index from
http://download.eclipse.org/eclipse/updates/4.4/ (0B at 0B/s)
[INFO] Adding repository http://download.eclipse.org/eclipse/updates/4.4
[INFO] Fetching p2.index from
http://download.eclipse.org/tools/orbit/downloads/drops/R20140525021250/repository/
(0B at 0B/s)
[INFO] Adding repository
http://download.eclipse.org/tools/orbit/downloads/drops/R20140525021250/repository
[INFO] Adding repository
http://download.eclipse.org/technology/swtbot/releases/2.3.0
[INFO] Adding repository
http://download.eclipse.org/technology/babel/update-site/R0.12.1/luna
[INFO] Resolving dependencies of MavenProject:
org.apache.directory.studio:org.apache.directory.studio.aciitemeditor:2.0.0-SNAPSHOT
@ /Users/elecharny/apacheds/studio/plugins/aciitemeditor/pom.xml
...
[INFO] Resolving dependencies of MavenProject:
org.apache.directory.studio:org.apache.directory.studio.p2repositories.dependencies:2.0.0-SNAPSHOT
@ /Users/elecharny/apacheds/studio/p2repositories/dependencies/pom.xml
[INFO] {osgi.os=linux, osgi.ws=gtk,
org.eclipse.update.install.features=true, osgi.arch=x86}
[ERROR] Cannot resolve project dependencies:
[ERROR]   Software being installed:
org.apache.directory.studio.p2repositories.dependencies
raw:2.0.0.'SNAPSHOT'/format(n[.n=0;[.n=0;[-S]]]):2.0.0-SNAPSHOT
[ERROR]   Missing requirement:
org.apache.directory.studio.p2repositories.dependencies
raw:2.0.0.'SNAPSHOT'/format(n[.n=0;[.n=0;[-S]]]):2.0.0-SNAPSHOT requires
'org.apache.directory.api.util [1.0.0.M30]' but it could not be found
[ERROR]
[ERROR] See
http://wiki.eclipse.org/Tycho/Dependency_Resolution_Troubleshooting for
help.
[ERROR] Cannot resolve dependencies of MavenProject:
org.apache.directory.studio:org.apache.directory.studio.p2repositories.dependencies:2.0.0-SNAPSHOT
@ /Users/elecharny/apacheds/studio/p2repositories/dependencies/pom.xml:
See log for details -> [Help 1]


I was able to run the first part of the build (ie, pom-first), but the
mvn clean install fails with the error I shown. I have doomed
.m2/repositoy/p2, .m2/repository/org/apache/directory, deployed apacheds...

Any idea ?

Mime
View raw message