directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Xu, Yaning" <yaning...@intel.com>
Subject RE: Need help about ApacheDS using Mavibot for the LDAP backend work support for Kerby
Date Thu, 04 Jun 2015 03:26:07 GMT
Hi Kiran,

As you say, we can use the FrameworkRunner from the excellent test suite that ApacheDS has
to supply ldap server. However, do you know how to specify a kerbores schema to the ldap server?

Regards,

Yaning

rom: Kiran Ayyagari [mailto:kayyagari@apache.org]
Sent: Thursday, May 28, 2015 11:49 AM
To: Apache Directory Developers List
Subject: Re: Need help about ApacheDS using Mavibot for the LDAP backend work support for
Kerby



On Thu, May 28, 2015 at 11:27 AM, Zheng, Kai <kai.zheng@intel.com<mailto:kai.zheng@intel.com>>
wrote:
Yaning,

It looks like not easy to embed ApacheDS in the target backend at least for me to too. Maybe
we could start with support a standalone LDAP server first? Hope we could move on. Thanks.

as stated in my earlier reply, please do not attempt to embed any LDAP server in Kerby.
otoh, you don't need an external server to test this new backend, just use the FrameworkRunner
from the excellent test suite that ApacheDS has, using this you can start/stop ApacheDS
in your tests.
Regards,
Kai

From: Zheng, Kai [mailto:kai.zheng@intel.com<mailto:kai.zheng@intel.com>]
Sent: Wednesday, May 27, 2015 9:18 AM
To: Apache Directory Developers List
Subject: RE: Need help about ApacheDS using Mavibot for the LDAP backend work support for
Kerby

Thanks Yaning for the take, working on the LDAP backend support for Kerby.

Hi Kiran,

Would you let know what are the least modules required to embed the Directory Server with
Mavibot? Is there any sample application doing so? Thanks.

Regards,
Kai

From: Xu, Yaning [mailto:yaning.xu@intel.com]
Sent: Tuesday, May 26, 2015 3:54 PM
To: Apache Directory Developers List
Subject: Need help about ApacheDS using Mavibot for the LDAP backend work support for Kerby

HI all,

I’m working on the LDAP backend using Mavibot for Kerby. Below are the deps I added to the
pom.xml, but failed getting the following errors. What did I missed? I’ve tried very much.
Thanks for the help.

   <dependency>
      <groupId>org.apache.directory.server</groupId>
      <artifactId>apacheds-core-api</artifactId>
      <version>2.0.0-M20</version>
      <scope>compile</scope>
    </dependency>
    <dependency>
      <groupId>org.apache.directory.server</groupId>
      <artifactId>apacheds-interceptor-kerberos</artifactId>
      <version>2.0.0-M20</version>
      <scope>compile</scope>
    </dependency>
    <dependency>
      <groupId>org.apache.directory.server</groupId>
      <artifactId>apacheds-protocol-shared</artifactId>
      <version>2.0.0-M20</version>
      <scope>compile</scope>
    </dependency>
    <dependency>
      <groupId>org.apache.directory.server</groupId>
      <artifactId>apacheds-protocol-kerberos</artifactId>
      <version>2.0.0-M20</version>
      <scope>compile</scope>
    </dependency>
    <dependency>
      <groupId>org.apache.directory.server</groupId>
      <artifactId>apacheds-ldif-partition</artifactId>
      <version>2.0.0-M20</version>
      <scope>compile</scope>
    </dependency>
    <dependency>
      <groupId>org.apache.directory.server</groupId>
      <artifactId>apacheds-mavibot-partition</artifactId>
      <version>2.0.0-M20</version>
      <scope>compile</scope>
    </dependency>
    <dependency>
      <groupId>org.apache.directory.server</groupId>
      <artifactId>apacheds-protocol-ldap</artifactId>
      <version>2.0.0-M20</version>
      <scope>compile</scope>
    </dependency>
    <dependency>
      <groupId>org.apache.directory.api</groupId>
      <artifactId>api-ldap-schema-parent</artifactId>
      <version>1.0.0-M20</version>
    </dependency>
    <dependency>
      <groupId>org.apache.directory.api</groupId>
      <artifactId>api-ldap-schema-data</artifactId>
      <version>1.0.0-M20</version>
    </dependency>
    <dependency>
      <groupId>org.apache.directory.api</groupId>
      <artifactId>api-asn1-api</artifactId>
      <version>1.0.0-M20</version>
    </dependency>
  </dependencies>

java.lang.NoClassDefFoundError: org/apache/directory/api/ldap/schema/loader/SchemaEntityFactory
                at org.apache.directory.server.core.api.schema.registries.synchronizers.SchemaSynchronizer.<init>(SchemaSynchronizer.java:99)
                at org.apache.directory.server.core.api.schema.registries.synchronizers.RegistrySynchronizerAdaptor.<init>(RegistrySynchronizerAdaptor.java:130)
                at org.apache.directory.server.core.api.schema.SchemaPartition.doInit(SchemaPartition.java:222)
                at org.apache.directory.server.core.api.partition.AbstractPartition.initialize(AbstractPartition.java:89)
                at org.apache.directory.server.core.DefaultDirectoryService.initialize(DefaultDirectoryService.java:1795)
                at org.apache.directory.server.core.DefaultDirectoryService.startup(DefaultDirectoryService.java:1244)


Regards,
Yaning



--
Kiran Ayyagari
http://keydap.com
Mime
View raw message