directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stefan Seelmann (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (DIRSTUDIO-1042) Fix logging system
Date Fri, 01 May 2015 14:52:06 GMT

     [ https://issues.apache.org/jira/browse/DIRSTUDIO-1042?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Stefan Seelmann updated DIRSTUDIO-1042:
---------------------------------------
    Description: 
The logging system is broken. There seem to be multiple issues.

1. When starting Studio a message like this is printed:

{noformat}
log4j:WARN No appenders could be found for logger (org.apache.directory.api.ldap.model.schema.parsers.AbstractSchemaParser).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for more info.
{noformat}

In API and ApacheDS bundles we use slf4j. Currently we add slf4j-log4j12 binding and log4j
bundles. However there is no log4j.properties configuration.

One approach is to keep log4j add a Fragement-Host for log4j that contains the log4j.properties.

Another approach is to remove log4j and add our own slf4j binding that forwards logs to Eclipse/OSGI
log service.

2. When running SWTBot tests lot of server logs are printed ot stdout.




  was:
The logging system is broken. There seem to be multiple issues.

1. When starting Studio a message like this is printed:

{noformat}
log4j:WARN No appenders could be found for logger (org.apache.directory.api.ldap.model.schema.parsers.AbstractSchemaParser).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for more info.
{noformat}

2. When running SWTBot tests lot of server logs are printed ot stdout.



> Fix logging system
> ------------------
>
>                 Key: DIRSTUDIO-1042
>                 URL: https://issues.apache.org/jira/browse/DIRSTUDIO-1042
>             Project: Directory Studio
>          Issue Type: Bug
>            Reporter: Stefan Seelmann
>             Fix For: 2.0.0-M9
>
>
> The logging system is broken. There seem to be multiple issues.
> 1. When starting Studio a message like this is printed:
> {noformat}
> log4j:WARN No appenders could be found for logger (org.apache.directory.api.ldap.model.schema.parsers.AbstractSchemaParser).
> log4j:WARN Please initialize the log4j system properly.
> log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for more info.
> {noformat}
> In API and ApacheDS bundles we use slf4j. Currently we add slf4j-log4j12 binding and
log4j bundles. However there is no log4j.properties configuration.
> One approach is to keep log4j add a Fragement-Host for log4j that contains the log4j.properties.
> Another approach is to remove log4j and add our own slf4j binding that forwards logs
to Eclipse/OSGI log service.
> 2. When running SWTBot tests lot of server logs are printed ot stdout.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message