directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Emmanuel Lecharny (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (DIRSERVER-2060) Bind not working after server startup
Date Tue, 21 Apr 2015 23:46:59 GMT

    [ https://issues.apache.org/jira/browse/DIRSERVER-2060?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14506035#comment-14506035
] 

Emmanuel Lecharny commented on DIRSERVER-2060:
----------------------------------------------

yes. Thus the comment I have added a very long time :

{code}
            // TODO : we should refactor that.
            // try each authenticator
{code}

Anyway, I have fixed the pb by disabling the delegating authenticator atm (and by making the
use of the delegateBaseDN mandatory).

> Bind not working after server startup
> -------------------------------------
>
>                 Key: DIRSERVER-2060
>                 URL: https://issues.apache.org/jira/browse/DIRSERVER-2060
>             Project: Directory ApacheDS
>          Issue Type: Bug
>            Reporter: Stefan Seelmann
>            Priority: Blocker
>             Fix For: 2.0.0-M20
>
>
> When starting the server sometimes it is not possible to bind to the server. In that
case the following error is returned to the client:
> {noformat}
> INVALID_CREDENTIALS: Bind failed: ERR_229 Cannot authenticate user uid=admin,ou=system
> {noformat}
> Same error is reproducable in UberJarMainTest, it fails sporadically on my machine (Linux)
and on Jenkins (https://builds.apache.org/view/A-D/view/Directory/job/dir-apacheds-ubuntu-deploy/1680/org.apache.directory.server$apacheds-service/testReport/org.apache.directory.server/UberJarMainTest/serviceInstanceTest/)



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message