directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Emmanuel Lecharny (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (DIRSERVER-2060) Bind not working after server startup
Date Tue, 21 Apr 2015 23:02:58 GMT

    [ https://issues.apache.org/jira/browse/DIRSERVER-2060?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14505967#comment-14505967
] 

Emmanuel Lecharny commented on DIRSERVER-2060:
----------------------------------------------

Why would be use the {{DelegatingAuthenticator}} at first ??? This makes no sense !

For standard servers, the {{DelegatingAuthenticator}} should not be activated by default,
and if it's set, at least the {{delegateBaseDn}} should be used to avoid calling this {{Authenticator}}
from the root DN.

Currently, here is the configuration for this {{Authenticator}} :

{code}
dn: ads-authenticatorid=delegatingauthenticator,ou=authenticators,ads-interceptorId=authenticationInterceptor,ou=interceptors,ads-directoryServiceId=default,ou=config
ads-authenticatorid: delegatingauthenticator
objectclass: top
objectclass: ads-base
objectClass: ads-authenticator
objectClass: ads-authenticatorImpl
ads-authenticatorClass: org.apache.directory.server.core.authn.DelegatingAuthenticator
ads-enabled: TRUE
{code}

I'll set the {{ads-enabled}} attribute to false.

> Bind not working after server startup
> -------------------------------------
>
>                 Key: DIRSERVER-2060
>                 URL: https://issues.apache.org/jira/browse/DIRSERVER-2060
>             Project: Directory ApacheDS
>          Issue Type: Bug
>            Reporter: Stefan Seelmann
>            Priority: Blocker
>             Fix For: 2.0.0-M20
>
>
> When starting the server sometimes it is not possible to bind to the server. In that
case the following error is returned to the client:
> {noformat}
> INVALID_CREDENTIALS: Bind failed: ERR_229 Cannot authenticate user uid=admin,ou=system
> {noformat}
> Same error is reproducable in UberJarMainTest, it fails sporadically on my machine (Linux)
and on Jenkins (https://builds.apache.org/view/A-D/view/Directory/job/dir-apacheds-ubuntu-deploy/1680/org.apache.directory.server$apacheds-service/testReport/org.apache.directory.server/UberJarMainTest/serviceInstanceTest/)



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message