directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stefan Seelmann (JIRA)" <j...@apache.org>
Subject [jira] [Created] (DIRAPI-233) OSGi: Import package range for slf4j
Date Thu, 16 Apr 2015 20:10:58 GMT
Stefan Seelmann created DIRAPI-233:
--------------------------------------

             Summary: OSGi: Import package range for slf4j
                 Key: DIRAPI-233
                 URL: https://issues.apache.org/jira/browse/DIRAPI-233
             Project: Directory Client API
          Issue Type: Improvement
    Affects Versions: 1.0.0-M29
            Reporter: Stefan Seelmann
            Assignee: Stefan Seelmann
            Priority: Minor
             Fix For: 1.0.0-M30


Request from Benjamin Abernathy:


I need to deploy version 1.0.0-M30 of the API bundles into an instance
of ServiceMix 5.3.0. Unfortunately ServiceMix (actually Karaf I think)
includes slf4j as a system bundle so its headers are made available to
all bundles. This makes it not possible to install the LDAP API bundles
because the system exports version 1.7.7 and the API bundles require
1.7.10. 

Would it be possible to open up the import version to import a wider
range of versions? For example, perhaps [1.7.0,1.8.0).

https://mail-archives.apache.org/mod_mbox/directory-api/201504.mbox/%3C1428355583.368130.249955045.52BFA2EA%40webmail.messagingengine.com%3E



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message