directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Emmanuel Lécharny <elecha...@gmail.com>
Subject Re: [Vote] Support only Java 7 for all the components
Date Fri, 09 Jan 2015 00:06:42 GMT
Le 08/01/15 21:31, Stefan Seelmann a écrit :
> On 01/08/2015 10:50 AM, Emmanuel Lécharny wrote:
>> Le 08/01/15 10:39, Colm O hEigeartaigh a écrit :
>>> +1. I'd suggest though releasing one more version supporting JDK 1.6 to
>>> allow users time to upgrade.
>> Sure. I was not explicit, but we *can* (§and should at this point) keep
>> the source target to be 1.6
> When I saw the vote and your text I *implicitely* thought you mean Java
> source and compiler target version. Explicit is better than implicit :P

Ok, my bad here. I have been influenced by the suggestion to keep Java 6
as a version we should support for the server, and I wrote that might be
a good idea to use Java 7 to build teh server but keeping Java 6 as a
JVM we can use to run the server.

Considering the dozen errors in ApacheDS with Java 6, I think it's time
to be a bit more drastic here and say we only support Java7 for build
and run.

Sorry for the confusion.



Mime
View raw message