directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Seelmann <m...@stefan-seelmann.de>
Subject Re: [Studio] heads up
Date Sun, 21 Dec 2014 17:40:53 GMT
On 12/21/2014 01:57 PM, Emmanuel Lécharny wrote:
> Le 21/12/14 12:01, Stefan Seelmann a écrit :
>> On 12/21/2014 09:04 AM, Emmanuel Lécharny wrote:
>>>>> 5) OSGi does not really like SNAPSHOT a lot. I still have to firgure
>>>>> oiut how to use them (there must be a solution, I just didn't had time
>>>>> to investigate too much)
>>>> Right, instead of -SNAPSHOT one has to use .qualifier. The
>>>> maven-bundle-plugin should convert that automatically. But I agree it is
>>>> confusing.
>>> removed rant
>> Ok, but for dependency version it is still possible to use snapshot when
>> following the version scheme x.y.z.qualifier, e.g. 1.0.0.M27-SNAPSHOT is
>> a vaild version. Maven-bundle-plugins takes care to create such a valid
>> OSGi version.

I was wrong again. The maven-bundle-plugin converts the module version
2.0.0-SNAPSHOT to 2.0.0.SNAPSHOT in the manifest.mf, so far so good. But
then tycho complains because it expects that Bundle-Version is
2.0.0.qualifier. I'll try to set the version of pom-first.xml to
2.0.0.qualifier...

Kind Regards,
Stefan






Mime
View raw message