directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Seelmann <m...@stefan-seelmann.de>
Subject Re: Validation of ApacheDS OSGi bundles
Date Thu, 11 Dec 2014 22:41:36 GMT
On 12/11/2014 09:09 PM, Emmanuel L├ęcharny wrote:
> Another question :
> 
> we have imports in LDAP API which may be problematic at some point :
> 
>     org.apache.commons.lang;version="2.6"
> 
> shouldn't we declare that instead ? :
> 
>     org.apache.commons.lang;version="[2.6,3)"
> 
> If so, how do we make Felix generate the MANIFEST from what we decalre
> in the pom.xml ?
> 
> (I'm refering to schema-converter which has such a commons.long
> declaration, and there are some <![CDATA[ ... ]]> declaration in the
> polm, not sure it's related)

In schema-converter I tried to achieve such a version range. Adding it
to the instructions didn't work. Then I found somewhere in the internet
the hint with CDATA but that didn't work either. What worked then is to
remove org.apache.commons.lang from instructions and put the "*" to the
end of the <Import-Packages> instruction.

Kind Regards,
Stefan



Mime
View raw message