directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Emmanuel L├ęcharny <elecha...@gmail.com>
Subject Re: Validation of ApacheDS OSGi bundles
Date Thu, 11 Dec 2014 16:59:19 GMT
Hi !

today, I spent some time on checking *all* the dependencies for LDAP
API, and all the imported and exported packages. I removed a few useless
dependencies.

One whic I think might be troublesome is a dependency on xml-apis 2.0.2
in dsml/parser, when it internally uses dom4j, which depends on xml-apis
1.0.b2. That *might* explain the pb we have when trying to build Studio
with the latest API version (not sure though).

I still have a few modules to check, then I'll have to test the build
with a API 1.0.0-M27-SNAPSHOT, which is everything but simple (I'm
afraid I'lm have to update the various manifest with the generated
versions, which is all but funny...)

Stefan, do you have a better idea ?

Mime
View raw message