directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Emmanuel Lécharny <elecha...@gmail.com>
Subject Re: [Studio] Eclipse luna issues...
Date Mon, 08 Dec 2014 20:47:55 GMT
Le 08/12/14 19:26, Stefan Seelmann a écrit :
> On 12/08/2014 06:25 PM, Emmanuel Lécharny wrote:
>> Hi,
>>
>> today, I had to quit and restart Syudio (luna), and I'm a bit surprised,
>> because all of a sudden, my studio projects where marked with a lot of
>> errors - while I was able to successfully launch Studio from my env the
>> day before -.
>>
>> It seems to complain about many missing dependencies (all of them ours :
>> ldap API and apacheds).
> I think those problems are related to the target platform. In such a
> case I'd recommend to open the
>
>     eclipse-target-platform/eclipse-target-platform.target
>
> file, wait till the resolution is finished (the first time this takes 30
> seconds, see progress indicator or progress view), and hopefully it
> doesn't show any errors. Then click the "Set as Target Platform" link in
> the top right corner of the editor. Just yesterday I added a README that
> describes this procedure.

Ah, I missed this step !

I tried, but it's not really succesfull. i'll try into another workspace.
>
> Another thing is to make sure (currently) that your workspace only
> contains Studio project, no others like ApacheDS or Shared. The reason
> is that Eclipse switches to workspace resolution instead of using the
> target platform. I'm not totally sure what the reason is, but think that
> transitive dependencies of ApacheDS/Shared can't be resolved. We'll need
> to figure that out, but for now please use a separate workspace.

Okie.
>
> I hope you can get it working again...

Me too :-) It was working super well before !
>
>> I fixed a few others (poi, xerces, odfdom).
> Those are not required to be OSGi bundles. Currently we copy those jars
> into the lib folder and use them as "embedded artifacts", see
> ldapbrowser.core/pom.xml. But it doesn't harm, maybe we can change the
> way we use them.

I saw a pb with xpp3. on one hand, the m2 repo contain a version 1.1.4c,
on the other hand, we declare a version 1.1.0.4c. I think this is to
please Felix vzersion dependencies, which does not like the '4c'. But
isn't it probematic to have 2 different versions ?

As it's a transitive dependency of dom4j, I wonder if it's not the
reason why we have this weird error :

[INFO] {osgi.ws=gtk, osgi.os=linux, osgi.arch=x86,
org.eclipse.update.install.features=true}
[ERROR] Cannot resolve project dependencies:
[ERROR]   Software being installed:
org.apache.directory.api.dsmlv2.parser 1.0.0.M26
[ERROR]   Missing requirement: org.apache.directory.api.dsmlv2.parser
1.0.0.M26 requires 'package org.dom4j 1.6.1' but it could not be found
[ERROR]


when trying to upgrade to LDAP API 1.0.0-M26 ?

Thanks !


Mime
View raw message