directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Seelmann <m...@stefan-seelmann.de>
Subject Re: [Studio] Eclipse luna issues...
Date Mon, 08 Dec 2014 18:26:13 GMT
On 12/08/2014 06:25 PM, Emmanuel L├ęcharny wrote:
> Hi,
> 
> today, I had to quit and restart Syudio (luna), and I'm a bit surprised,
> because all of a sudden, my studio projects where marked with a lot of
> errors - while I was able to successfully launch Studio from my env the
> day before -.
> 
> It seems to complain about many missing dependencies (all of them ours :
> ldap API and apacheds).

I think those problems are related to the target platform. In such a
case I'd recommend to open the

    eclipse-target-platform/eclipse-target-platform.target

file, wait till the resolution is finished (the first time this takes 30
seconds, see progress indicator or progress view), and hopefully it
doesn't show any errors. Then click the "Set as Target Platform" link in
the top right corner of the editor. Just yesterday I added a README that
describes this procedure.

Another thing is to make sure (currently) that your workspace only
contains Studio project, no others like ApacheDS or Shared. The reason
is that Eclipse switches to workspace resolution instead of using the
target platform. I'm not totally sure what the reason is, but think that
transitive dependencies of ApacheDS/Shared can't be resolved. We'll need
to figure that out, but for now please use a separate workspace.

I hope you can get it working again...

> I fixed a few others (poi, xerces, odfdom).

Those are not required to be OSGi bundles. Currently we copy those jars
into the lib folder and use them as "embedded artifacts", see
ldapbrowser.core/pom.xml. But it doesn't harm, maybe we can change the
way we use them.

> I think there is more to get all working.
> 
> Otherwise, after having changed the MANIFEST.MF to have 'qualifier'
> instead of SNAPSHOT, and after having added the missing poi, odfdom and
> xerces dependencies, I was able to run successfully a mvn clean install
> on Studuio, which is kind of refreshing...

Ok, good.

Kind Regards,
Stefan


Mime
View raw message