directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Roman Muentener (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (DIRSERVER-1995) Installation problem through Linux Binary
Date Fri, 29 Aug 2014 07:25:53 GMT

    [ https://issues.apache.org/jira/browse/DIRSERVER-1995?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14114969#comment-14114969
] 

Roman Muentener commented on DIRSERVER-1995:
--------------------------------------------

sed -e "s;@user@;${RUN_AS_USER};" ../server/bin/apacheds > ../server/bin/apacheds.tmp
verifyExitCode
sed -e "s;@group@;${RUN_AS_GROUP};" ../server/bin/apacheds > ../server/bin/apacheds.tmp
verifyExitCode
mv ../server/bin/apacheds.tmp ../server/bin/apacheds

There's a mv missing after replacing the _at_ user _at_ causing the replacement of group overwriting
the replacement of _at_ user _at_.

> Installation problem through Linux Binary
> -----------------------------------------
>
>                 Key: DIRSERVER-1995
>                 URL: https://issues.apache.org/jira/browse/DIRSERVER-1995
>             Project: Directory ApacheDS
>          Issue Type: Bug
>    Affects Versions: 2.0.0-M17
>         Environment: Linux, Debian
>            Reporter: Roman Muentener
>            Priority: Minor
>              Labels: installation
>
> After installation through the *.bin calling the script in init.d for the default instance
results in:
> No passwd entry for user '@user@'
> The init.d script forwards to the script in /opt 
> which contains the line
> RUN_AS_USER="@user@"
> This line can be trivially corrected by manually changing it to contain the correct username
(as given to the installation script). 
> However, the installation script should fill in the user correctly.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message