directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Fortunato Margariti (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (DIRSERVER-1979) Adding subentries after restarting server, aren't found.
Date Thu, 22 May 2014 16:25:02 GMT

    [ https://issues.apache.org/jira/browse/DIRSERVER-1979?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14006089#comment-14006089
] 

Fortunato Margariti commented on DIRSERVER-1979:
------------------------------------------------

the problem happen only when restart the server. if i create the mentioned tree structure
with ldif, and add subentries without restarting the server, that subentries are founded with
the search also if they are added on a leaf. We have found the problem after same days when
we  restarted the server. The problem seems to happen only on subentries that we want to add
on entry created before the restarting. (this was the reason because i  thought that the problem
was related on DIRSERVER-1976), but doesn't happen if we create before a NEW entry and then
the subentry.

> Adding subentries after restarting server, aren't found.
> --------------------------------------------------------
>
>                 Key: DIRSERVER-1979
>                 URL: https://issues.apache.org/jira/browse/DIRSERVER-1979
>             Project: Directory ApacheDS
>          Issue Type: Bug
>          Components: ldap
>    Affects Versions: 2.0.0-M16, 2.0.0-M17
>         Environment: windows seven.
>            Reporter: Fortunato Margariti
>
> Suppose to have the following situation on the Server (created with ldif):
> dc=xxx,dc=com
> ........ou=groups
> .............. cn=aim
> .............. cn=ais
> .................... cn=aisOperator
> .............. cn=admin
> If you stop and restart the server and then create a subentry (named for example "child")
under any leaf on the tree (in this case under "aim" or "aisOperator" or "admin"), happen
the following:
> 1) the new entry is not visible with a search that start
>  from ou=groups,dc=xxx,dc=com 
> 2) the new entry is visible only if the search start from dc=xxx,dc=com
>    or starting from the leaf: ou=aim,ou=groups,dc=xxx,dc=com
> 3) If you perform an ldif export on ou=groups,dc=xxx,dc=com, you can't find the new added
subentry.
> 4) if the subentry is created under cn=ais (that is not a leaf because has already a
subentry) the new "child" entry is founded by the search
> I was thinking that the problem was related to DIRSERVER-1976 (solved on M17) but we
have the same problems also on this version.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message