directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Emmanuel Lecharny <elecha...@apache.org>
Subject Re: ApacheDS 2.0.0-M16 not running on windows 7 64 bit
Date Tue, 13 May 2014 02:23:09 GMT
Hmmm...

Looking at the wrapper plugin, we don't support windows 64bits installers.
Not in M16, nor in M15. In fact, due to the license restriction, we had to
keep an old version of the wrapper (3.2.3 :
http://wrapper.tanukisoftware.com/downloads/3.2.3/) and even in the latest
version (3.5.24) the windows 64 bits wrapper for windows is not available
for free (http://wrapper.tanukisoftware.com/doc/english/download.jsp : "
64-bit Windows versions of the Java Service Wrapper are not currently being
made available in the Community Edition.").

Unless we change the tool used to wrap the server, we won't be able to
support Windows 64bits. Although, it should work in 32bits.

I do think that when you use M15 on your 64 bits machine, it switches to 32
bits silently.


On Mon, May 12, 2014 at 11:19 PM, Boxer, Aaron <Aaron.Boxer@uhn.ca> wrote:

> Thanks, Emmanuel.
>
>
> I get this warning in the log file:
>
>
>
> INFO   | jvm 1    | 2014/05/12 15:44:21 | WARNING - Unable to load the
> Wrapper's native library 'wrapper.dll'.
> INFO   | jvm 1    | 2014/05/12 15:44:21 |           The file is located on
> the path at the following location but
> INFO   | jvm 1    | 2014/05/12 15:44:21 |           could not be loaded:
> INFO   | jvm 1    | 2014/05/12 15:44:21 |             C:\Program Files
> (x86)\ApacheDS\bin\..\lib\wrapper.dll
> INFO   | jvm 1    | 2014/05/12 15:44:21 |           Please verify that the
> file is readable by the current user
> INFO   | jvm 1    | 2014/05/12 15:44:21 |           and that the file has
> not been corrupted in any way.
> INFO   | jvm 1    | 2014/05/12 15:44:21 |           One common cause of
> this problem is running a 32-bit version
> INFO   | jvm 1    | 2014/05/12 15:44:21 |           of the Wrapper with a
> 64-bit version of Java, or vica versa.
> INFO   | jvm 1    | 2014/05/12 15:44:21 |           This is a 64-bit JVM.
> INFO   | jvm 1    | 2014/05/12 15:44:21 |           Reported cause:
> INFO   | jvm 1    | 2014/05/12 15:44:21 |             C:\Program Files
> (x86)\ApacheDS\lib\wrapper.dll: Can't load IA 32-bit .dll on a AMD 64-bit
> platform
> INFO   | jvm 1    | 2014/05/12 15:44:21 |           System signals will
> not be handled correctly.
>
>
>
> But, even with the warning, M15 will start.  M16 will time out.
>
> Yes, I am using a 64 bit JVM, but M15 is happy, while M16 is not (and M16
> didn't work with 32 bit JVM either).
>
> Unfortunately, I don't have time to debug much further on this issue.
>
> Hope that helps,
> Aaron
>
>
> -----Original Message-----
> From: Emmanuel Lécharny [mailto:elecharny@gmail.com]
> Sent: Monday, May 12, 2014 5:16 PM
> To: Apache Directory Developers List
> Subject: Re: ApacheDS 2.0.0-M16 not running on windows 7 64 bit
>
> Le 12/05/2014 21:46, Boxer, Aaron a écrit :
> > Just verified that this is not an issue for M15 from last year.
>
> That's extremelly weird. We haven't changed this part of the server in M16.
>
> What is the exact error you get ? I suspect that it's more a problem with
> the delay to start the server, which will timeout and fail after 30 seconds.
>
>
>
> This e-mail may contain confidential and/or privileged information for the
> sole use of the intended recipient.
> Any review or distribution by anyone other than the person for whom it was
> originally intended is strictly prohibited.
> If you have received this e-mail in error, please contact the sender and
> delete all copies.
> Opinions, conclusions or other information contained in this e-mail may
> not be that of the organization.
>



-- 
Regards,
Cordialement,
Emmanuel Lécharny
www.iktek.com

Mime
View raw message