directory-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shai Levit (JIRA)" <j...@apache.org>
Subject [jira] [Created] (DIRSTUDIO-979) Crash with port already in use issues
Date Thu, 03 Apr 2014 21:57:14 GMT
Shai Levit created DIRSTUDIO-979:
------------------------------------

             Summary: Crash with port already in use issues
                 Key: DIRSTUDIO-979
                 URL: https://issues.apache.org/jira/browse/DIRSTUDIO-979
             Project: Directory Studio
          Issue Type: Bug
          Components: studio-connection
    Affects Versions: 2.0.0-M8 (2.0.0.v20130628)
         Environment: Mac OS X 10.9.2
            Reporter: Shai Levit
             Fix For: 2.0.0-M8 (2.0.0.v20130628)


Apache studio seems to crash often both in the stand-alone version and the Eclipse Kepler
plugin. The issue once it crashes is that I cannot reconnect using the port. It states that
the port is already in use. This prevents the server from starting. Oddly, the connection
will still work, but the server will not start and hence other issues start to arise. To sometimes
solve this issue, and this does not always works, is to go to the servers folder and delete
the .dirservice.lock
But this solution does not bode well, since the crashes still continue and eventually this
option fails as well. I end up deleting the entire download and starting fresh.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message